Bug 81854 - Import of Excel document produced by Numbers displays random borders on cells
Summary: Import of Excel document produced by Numbers displays random borders on cells
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-28 22:57 UTC by Paul Davis
Modified: 2015-04-01 12:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing random cell borders in spreadsheet (336.68 KB, image/jpeg)
2014-07-31 21:33 UTC, Paul Davis
Details
Test case - wobbly border styles (26.92 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-08-04 00:01 UTC, Paul Davis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Davis 2014-07-28 22:57:38 UTC
When a spreadsheet document is saved, and then reopened, random cells have borders around them. I repeatedly clear the borders, only to have them appear again.
Comment 1 A (Andy) 2014-07-31 19:29:39 UTC
for me this is not reproducible with LO 4.3.0.4 (Win 8.1), could you please give more information how reproduce it, can you reproduce it with a new file?
Comment 2 Paul Davis 2014-07-31 21:33:29 UTC
Created attachment 103770 [details]
Screenshot showing random cell borders in spreadsheet

Using LO on Mac Mavericks whenever opening a sheet random cells have borders. After clearing all borders, then reopening they reappear.
Comment 3 ign_christian 2014-08-01 03:22:59 UTC
Paul, please provide exact reproducible steps to generate the problem. Otherwise it's hard for others to confirm.
Comment 4 Paul Davis 2014-08-04 00:01:40 UTC
Created attachment 103952 [details]
Test case - wobbly border styles

Here is an export of one of the sheets having problems. Perhaps they are an artefact from exporting this sheet from Apple Numbers when I converted to LO. I've since started a new sheet, and am not having the cell borders randomly appearing.
Comment 5 Buovjaga 2014-11-26 13:08:41 UTC
Should be UNCONFIRMED. Hello, Mac testers!
Comment 6 Alex Thurgood 2014-11-30 12:24:39 UTC
The xlsx file shows random boders in both Excel 2011 and Numbers.


As the origin of this particular document has not been ascertained and the user has reported that new documents work fine, setting as closed worksforme.

@Paul : if you can provide the original document, the please do, so that we can reopen if necessary.

There are known issues when exporting to xlsx from Numbers, even when you reopen in Excel. One can hardly blame LO if it gets import wrong on a format that Numbers doesn't export to correctly.
Comment 7 Alex Thurgood 2014-11-30 12:25:57 UTC
Changed title.
Comment 8 Alex Thurgood 2014-11-30 12:26:41 UTC
In fact, thiusd appears to be a Numbers bug, so notourbug.