Download it now!
Bug 81863 - Rulers extend to the edge, instead of floating freely (like they did in 4.2)
Summary: Rulers extend to the edge, instead of floating freely (like they did in 4.2)
Status: RESOLVED DUPLICATE of bug 51534
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.3 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-29 06:44 UTC by fuer_kommentare
Modified: 2014-07-29 13:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (31.08 KB, image/png)
2014-07-29 06:44 UTC, fuer_kommentare
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fuer_kommentare 2014-07-29 06:44:12 UTC
Created attachment 103626 [details]
Screenshot

In 4.2 the rulers started to float freely, in 4.3 they do not however. They have a gray bar extending to the window borders again.

Would be nice if this can be fixed, the free rulers was one of the best UI decisions ever made.

Not sure if the ruler background came back, or if the paper background color so that ruler and paper have different background. All I know: the rulers are not floating anymore since 4.3.
Comment 1 fuer_kommentare 2014-07-29 07:02:24 UTC
Additional notes: The option menu (LibreOffice -> Appearance, the one with the color schemes) does NOT provide the exact same gray for the "Application Background" as the ruler background is using, and the ruler background is not changable in this menu. So I can't even fix this with custom settings.
Comment 2 Douglas Mencken 2014-07-29 07:56:59 UTC
These commits and bug reports looks related:

  - cbb9efa642ec3a7418136547c04eb2455ba1c821
      (Apr 30, 2014) "fdo#72142 lighter ruler default color"
      https://gerrit.libreoffice.org/gitweb?p=core.git;a=commitdiff;h=cbb9efa642ec3a7418136547c04eb2455ba1c821
      https://bugs.freedesktop.org/show_bug.cgi?id=72142 "Default Application Background is too much bright!"
   
  - b0cdd038ee192dcc0d83182a33fc8c0242ceb1dd
      (Jul 24, 2014) "fdo#51534 - rulers should have app-background by default (apparently)"
      https://gerrit.libreoffice.org/gitweb?p=core.git;a=commitdiff;h=b0cdd038ee192dcc0d83182a33fc8c0242ceb1dd
      https://bugs.freedesktop.org/show_bug.cgi?id=51534 "Ruler background doesn't change according to application background setting"

For somebody, it was "too much bright", now it is "the dark grey ugly bar extending the rulers to the window border" (quote from irc :)
Comment 3 fuer_kommentare 2014-07-29 13:01:38 UTC
Well, I don't care if it is light-grey or dark-gray, I only want the paper background and ruler background to be the same color, so that the rulers appear to be floating. ;)

I also remember this being listed as an optical feature for 4.2 somewhere (so, removing this in 4.3 should at least be noted and explained somewhere, if it was intentionally changed).

But wheter or not the rulers are floating in the future: it should at least be the same on all platforms - currently it seems only to be broken/different/nonfloating on Windows, but is still teh same on MAcOS and Linux as it was in 4.2.
Comment 4 fuer_kommentare 2014-07-29 13:04:31 UTC
Ah, I just saw in https://bugs.freedesktop.org/show_bug.cgi?id=51534 that it will be fixed in 4.3.1 - then this can be closed. :) I mark it as duplicate.

*** This bug has been marked as a duplicate of bug 51534 ***