Bug 81938 - FILEOPEN: DOCX Strict table size not retained
Summary: FILEOPEN: DOCX Strict table size not retained
Status: RESOLVED DUPLICATE of bug 79272
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: All All
: medium normal
Assignee: Not Assigned
Keywords: filter:docx
Depends on:
Blocks: OOXML-Import-Strict DOCX-Tables
  Show dependency treegraph
Reported: 2014-07-31 04:21 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-03 17:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

docx strict file (125.24 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-07-31 04:21 UTC, Yousuf Philips (jay) (retired)

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-07-31 04:21:39 UTC
Created attachment 103714 [details]
docx strict file

I downloaded < http://download.microsoft.com/documents/rus/microsoft4you/How_to_license_the_operating_system_Windows_8_new.docx > and opened it in Word 2013 and saved it as a docx strict. Then when opening the file in LibO master, 4.3.1 or 4.2.7, the tables on page 6 and 15 are crushed flat.

1) Open attached docx file
2) scroll to page 6

LibO 4.2.7 also has the table on page 1 crushed, which doesnt happen in 4.3.1 or master. I had reported a similar table being crashed flat in a docx strict file in bug 78508, but that was fixed in 4.3 alpha.
Comment 1 Kevin Suo 2014-08-02 06:07:45 UTC
Confirmed with version, Ubuntu 14.04 x64.

Set to NEW.
Comment 2 Yousuf Philips (jay) (retired) 2014-08-02 06:19:23 UTC
Found another instance of this issue with another docx strict document i outputted, attachment 103836 [details]. It crushed table appears on page 19 and 24.
Comment 3 Yousuf Philips (jay) (retired) 2014-08-02 22:38:38 UTC
My last comment was for LibO 4.3.1, while with the same file in 4.2.7, you will find the first crush table on page 6.
Comment 4 QA Administrators 2015-10-14 19:57:03 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-12-04 16:33:59 UTC Comment hidden (no-value)
Comment 6 Yousuf Philips (jay) (retired) 2015-12-07 14:53:50 UTC Comment hidden (no-value)
Comment 7 Buovjaga 2015-12-07 16:50:43 UTC Comment hidden (no-value)
Comment 8 Robinson Tryon (qubit) 2015-12-09 18:45:03 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2017-01-03 19:41:26 UTC Comment hidden (obsolete)
Comment 10 Yousuf Philips (jay) (retired) 2017-10-03 17:01:10 UTC

*** This bug has been marked as a duplicate of bug 79272 ***