Download it now!
Bug 81958 - FILEOPEN docx: Text or image missing from textbox containing image and grouped with any other shape
Summary: FILEOPEN docx: Text or image missing from textbox containing image and groupe...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:docx
Depends on:
Blocks: DOCX-Textbox DOCX-Grouped-Shapes
  Show dependency treegraph
 
Reported: 2014-07-31 10:13 UTC by Sushil Shinde
Modified: 2020-11-18 10:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
File contains image inside textbox and grouped with other shape. (80.44 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-07-31 10:13 UTC, Sushil Shinde
Details
File saved in MSO in new format (86.31 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-12-04 13:59 UTC, Timur
Details
File compared MSO 2016 LO 7.1+ (177.59 KB, image/png)
2020-09-23 06:22 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sushil Shinde 2014-07-31 10:13:55 UTC
Created attachment 103746 [details]
File contains image inside textbox and grouped with other shape.

Problem description: If I insert a picture inside a textbox and group that textbox with any other preset or custom shape then textbox and text from text box is missing from rendered group shape.

Steps to reproduce:
1. Create a docx file on MS Office 2007 version.
2. Insert a textbox and add some text to it.
3. Insert a picture inside textbox.
4. Add an any shape to page.
5. Group this new shape with textbox and save file as .docx.
6. Open saved file on latest LibreOffice master.
7. Save file as docx file again.

Current behavior:
1) TextBox with its text content is missing from rendered group shape. Only Picture and other shape is rendered.
2) Textbox from group shape should get exported properly.

Expected behavior:
1) It should render without any data loss.
2) LO should export file without any data loss.


** I tried text box with picture without grouping with any shape, It work perfectly. Problem is with grouping only.
              
Operating System: Ubuntu
Version: 4.4.0.0.alpha0+ Master
Comment 1 Jorendc 2014-07-31 12:03:46 UTC Comment hidden (obsolete)
Comment 2 Jorendc 2015-05-17 20:12:08 UTC
Still reproducible ,tested using Version: 5.0.0.0.alpha1+ (x64)
Build ID: 9d0c51daea67104349cac26de9839afa8baeb099
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-05-15_23:59:35
Locale: nl-BE (nl_BE)
Comment 3 QA Administrators 2016-09-20 09:41:28 UTC Comment hidden (obsolete)
Comment 4 Telesto 2016-12-06 12:48:36 UTC
Still reproducible:
Version: 5.4.0.0.alpha0+
Build ID: 33f5bc54aaa7fe7aa9335726e30f9c349155e04d
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-12-01_23:21:05
Locale: nl-NL (nl_NL); Calc: CL
Comment 5 Timur 2017-02-03 15:50:44 UTC
"Text" was there up to 4.0 beta 1, but without star and group, not a regression.
Comment 6 QA Administrators 2018-02-04 03:30:41 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2018-09-07 13:08:44 UTC
Still confirmed.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 033a68c49fe2b8aa397832d92d400eb0259ea809
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3_kde5; 
Locale: fi-FI (fi_FI.UTF-8); Calc: threaded
Built on September 5th 2018
Comment 8 sdc.blanco 2019-12-04 13:36:09 UTC
Could not repro

1.  Not possible to put an image (picture) in a textbox.
2.  Saving grouped text box and shape retains the text in the textbox.

Version: 6.4.0.0.beta1 (x64)
Build ID: 4d7e5b0c40ed843384704eca3ce21981d4e98920
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: en-US (en_DK); UI-Language: en-US
Calc: CL
Comment 9 Timur 2019-12-04 13:59:57 UTC
Created attachment 156298 [details]
File saved in MSO in new format

attachment 103746 [details] DOCX seems to be from MSO, older 2007 version. 
Opening it in LO master 6.5+ doesn't show text from textbox so it's a fileopen issue, unlike steps in Description. 
I attach DOCX saved in MSO as new version. It opens differently but wrong. 
I may have not understood comment 8, but I reproduce this bug.
Comment 10 sdc.blanco 2019-12-04 14:22:23 UTC
(In reply to Timur from comment #9)
> I may have not understood comment 8, but I reproduce this bug.

Maybe I have misunderstood the bug. 

As I understood comment #1, the text inside the textbox was supposed to be missing after being saved in a grouped shape as .docx and then reloaded.

This does not happen when I follow the procedure described in comment #1
(i.e., the text in the grouped textbox is still visible after saving the grouped textbox as .docx).

I also tried with your attachment 156298 [details] and again, saving as .docx and reloading still has "text" in the textbox (at least with 6.4.0.0.beta1)

That is what I could not reproduce (if that was supposed to be the bug).
Comment 11 Timur 2020-09-23 06:22:42 UTC
Created attachment 165783 [details]
File compared MSO 2016 LO 7.1+