Download it now!
Bug 82069 - FILEOPEN: RTF - Rectangle positioning, arrangement and color incorrect
Summary: FILEOPEN: RTF - Rectangle positioning, arrangement and color incorrect
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard:
Keywords: filter:rtf
Depends on:
Blocks: RTF-Shapes
  Show dependency treegraph
 
Reported: 2014-08-02 23:43 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-24 14:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
RTF in Word 2013 (163.65 KB, image/png)
2014-08-02 23:43 UTC, Yousuf Philips (jay) (retired)
Details
Red rectangle with fill set to none (269.93 KB, image/png)
2014-08-02 23:54 UTC, Yousuf Philips (jay) (retired)
Details
It is filled red in 4.4.0.0+ master (299.20 KB, image/png)
2014-08-03 15:12 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-08-02 23:43:54 UTC
Created attachment 103878 [details]
RTF in Word 2013

Steps:
1) Open attachment 103815 [details] in Word 2013 and convert to RTF, else open < https://drive.google.com/file/d/0B6qJrVIa0SAlbHNZaDRsYlVpQkU/edit?usp=sharing >
2) On page 1 you will see red and blue rectangles
3) The blue rectangle is supposed to be right below the image with the lady at a computer and the red rectangle is supposed to be behind the image, as can be seen in the attached screenshot of how it is in Word 2013
Comment 1 Yousuf Philips (jay) (retired) 2014-08-02 23:54:55 UTC
Created attachment 103879 [details]
Red rectangle with fill set to none

This was tested in 4.3.1.

In 4.1.6 and 4.2.7, the red rectangle is shown in white because its color is set to none and would be difficult to see, though it was red in 4.0.6.
Comment 2 Jorendc 2014-08-03 15:11:13 UTC
Reproducible.
It is filled red over here, tested using Windows 8.1 with LibreOffice Version: 4.4.0.0.alpha0+
Build ID: 6528607d34c9a2098ff5eec051fc9299ec37dfd7
TinderBox: Win-x86@39, Branch:master, Time: 2014-08-03_07:56:26
Comment 3 Jorendc 2014-08-03 15:12:41 UTC
Created attachment 103924 [details]
It is filled red in 4.4.0.0+ master
Comment 4 Jorendc 2014-08-03 15:14:19 UTC
(In reply to comment #2)
> It is filled red over here
(which is as Jay said the correct color)
Comment 5 Robinson Tryon (qubit) 2015-12-10 01:08:11 UTC Comment hidden (obsolete)
Comment 6 Miklos Vajna 2016-06-24 14:37:25 UTC
This looks sane on master, bisecting points out that my commit 37ecf082378a94d28d90b6f7639b0815484d9e3e (RTF import: fix handling of RTF_SHPFBLWTXT, 2014-08-13) fixed the appearing strange red rectangle.