Bug 82107 - FILEOPEN: RTF - Paragraph line spacing not retained
Summary: FILEOPEN: RTF - Paragraph line spacing not retained
Status: VERIFIED DUPLICATE of bug 81944
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
Keywords: bibisected, filter:rtf, regression
Depends on:
Blocks: RTF-Paragraph
  Show dependency treegraph
Reported: 2014-08-04 01:19 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-31 05:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

sample file (1.45 MB, application/rtf)
2014-08-04 01:19 UTC, Yousuf Philips (jay) (retired)
LibO 3.6 VS 4.3 (242.16 KB, image/png)
2014-08-04 01:20 UTC, Yousuf Philips (jay) (retired)

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-08-04 01:19:35 UTC
Created attachment 103959 [details]
sample file

1) Open attached file
2) Look at the paragraph below 'Standalone Virtual Machine'
3) Its paragraph spacing is set to single, while its set to 115% in 3.6.7

Tested in 4.3.1 and 4.2.5 on Linux. Regression that begin in 4.0.x.
Comment 1 Yousuf Philips (jay) (retired) 2014-08-04 01:20:20 UTC
Created attachment 103960 [details]
LibO 3.6 VS 4.3
Comment 2 Marina Latini 2014-08-04 09:11:11 UTC
Confirmed on Ubuntu 14.04 x86_64:
* Version:
* Build ID: 8cb75e905cef50a2d8a423443d3dcef5f1899027
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-07-30_04:47:13

block -> bug 81234 (meta bug for rtf filter)

@jay: Please, can you specify the OS?
Comment 3 Yousuf Philips (jay) (retired) 2014-08-04 22:20:18 UTC
I'm running Linux Mint. :)
Comment 4 Xisco Faulí 2014-08-05 11:04:40 UTC

f8b7f4b27eb8b3df4259a6d986607fd414f552af is the first bad commit
commit f8b7f4b27eb8b3df4259a6d986607fd414f552af
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Tue Dec 11 06:40:43 2012 +0000

    commit 9d83ad0e99ab182506be99f7d6a2bec7f6fbe8c6
    Author:     Tor Lillqvist <tml@iki.fi>
    AuthorDate: Mon Nov 26 21:39:43 2012 +0200
    Commit:     Tor Lillqvist <tml@iki.fi>
    CommitDate: Mon Nov 26 21:40:29 2012 +0200
        Use -dead_strip ld flag
        Change-Id: I39bb14e47654afd5425098fb4aad80a29f058d67

:100644 100644 aef1e548ce98a45bfe5985b09d2a8216ffffd30f b0da46998c97109b9daa17d2d77bd0d749078eb5 M	autogen.log
:100644 100644 0d03cdd08ac0b1a4e736e7a74465a8800ca981d1 795864ddee40f2bb7249ebd6d60f5623762b82de M	ccache.log
:100644 100644 ddd1deead2548e7237334d419220468f89fdc6a0 8e34813967ae6afef2690eed5ebf9dbc9b487b31 M	commitmsg
:100644 100644 c72be0167d41f6011e06840a042d290790db9a40 28db5af718a74e7bc071731d96ddc23fa7becff0 M	dev-install.log
:100644 100644 15937adfaadaa5398797fb14a5f5f45f32d03d77 d4b8e7cfbc1e86da4082dba3dc4867e9aea6f694 M	make.log
:040000 040000 87c1a75f4d31a803fecb37c3cfeef9ffba68873f c38ef1c4bf9cb5947072475530fc46b7bf53f08b M	opt

# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect good 8f4aeaad2f65d656328a451154142bb82efa4327
# bad: [9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02] source-hash-8600bc24bbc9029e92bea6102bff2921bc10b33e
git bisect bad 9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02
# good: [51b63dca7427db64929ae1885d7cf1cc7eb0ba28] source-hash-806d18ae7b8c241fe90e49d3d370306769c50a10
git bisect good 51b63dca7427db64929ae1885d7cf1cc7eb0ba28
# bad: [d65a58c31c8da044ef66ae4517fa2fe74cec0019] source-hash-2e053cf5ea4d93a2e1845e795a9c7fe1e08c84af
git bisect bad d65a58c31c8da044ef66ae4517fa2fe74cec0019
# good: [79e02001f27d33b3b478324ab6fba5683413b4d9] source-hash-b6c016da23d309b4ac7d154bc33a22397974ed73
git bisect good 79e02001f27d33b3b478324ab6fba5683413b4d9
# bad: [1e04c3b7ef40994ada3236fa8f90fbd1cdcea47e] source-hash-11e776023c89b3de690b37ffaed18ec996b9c207
git bisect bad 1e04c3b7ef40994ada3236fa8f90fbd1cdcea47e
# good: [5809284e8a6f97fe3b5beb037b6b80eeb9fe1058] source-hash-246ffb108c7e1f762f8d497750ad2414b85b99ef
git bisect good 5809284e8a6f97fe3b5beb037b6b80eeb9fe1058
# bad: [f8b7f4b27eb8b3df4259a6d986607fd414f552af] source-hash-9d83ad0e99ab182506be99f7d6a2bec7f6fbe8c6
git bisect bad f8b7f4b27eb8b3df4259a6d986607fd414f552af
# good: [7fa43e1a1b181ccdcb395c16788a66c591b63045] source-hash-41c2b0375773b2d2945d75e255ea6bb6c7fd378d
git bisect good 7fa43e1a1b181ccdcb395c16788a66c591b63045
# first bad commit: [f8b7f4b27eb8b3df4259a6d986607fd414f552af] source-hash-9d83ad0e99ab182506be99f7d6a2bec7f6fbe8c6
Comment 5 Miklos Vajna 2014-09-08 13:01:44 UTC
This is the same problem as bug 81944.

*** This bug has been marked as a duplicate of bug 81944 ***
Comment 6 Yousuf Philips (jay) (retired) 2014-09-08 14:26:33 UTC
Am i missing something Miklos as this one is about line spacing and bug 81944 is about words not retaining font name.
Comment 7 Yousuf Philips (jay) (retired) 2014-09-08 15:17:51 UTC
Build ID: 8e4defe4b59a72fbe82f94b26e233ba36640c739
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-09-02_01:46:56
Comment 8 Robinson Tryon (qubit) 2015-12-17 11:05:20 UTC Comment hidden (obsolete)