Download it now!
Bug 82120 - 3D animated model not working and incorrectly
Summary: 3D animated model not working and incorrectly
Status: RESOLVED DUPLICATE of bug 81181
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-04 07:42 UTC by Daniel
Modified: 2014-08-11 19:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
3D animated monster incorrectly (138.55 KB, image/png)
2014-08-04 07:45 UTC, Daniel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2014-08-04 07:42:41 UTC
I have download sample in Document Foundation wiki and that is 3D animated monster model to make sure this feature is worked. I have seen in Firefox with LibreOffice plug-in and open directly in LibreOffice app. But in fact, this feature is not working and incorrectly after view in both (browser plug-in and this app). Where is the problem or is there a component is not yet been installed?
Comment 1 Daniel 2014-08-04 07:45:18 UTC
Created attachment 103976 [details]
3D animated monster incorrectly

Nothing animated movement...?
Comment 2 Jean-Baptiste Faure 2014-08-06 05:16:49 UTC
Reproducible.
You need to select the 3D model to be able to launch the animation.
That said what I see with the odp file given in the Release Notes (https://wiki.documentfoundation.org/images/c/cc/Monster_gltf_model.odp) does not match the screencopy from the release notes but match the screencopy from the reporter.
When I click outside the 3D model LO 4.3.1.0.0+ crash without notice.

Best regards. JBF
Comment 3 Tamás Zolnai 2014-08-11 13:32:43 UTC
(In reply to comment #0)
> I have download sample in Document Foundation wiki and that is 3D animated
> monster model to make sure this feature is worked. I have seen in Firefox
> with LibreOffice plug-in and open directly in LibreOffice app. But in fact,
> this feature is not working and incorrectly after view in both (browser
> plug-in and this app). Where is the problem or is there a component is not
> yet been installed?

For playing a model there is two options:
1) Select the model and media toolbar will appear. There you can click play button.
2) Start the slideshow

When the model is played you can change the camera position by click & drag or
using W, S, A, D keys.
Comment 4 Tamás Zolnai 2014-08-11 13:34:02 UTC
(In reply to comment #2)
> Reproducible.
> You need to select the 3D model to be able to launch the animation.
> That said what I see with the odp file given in the Release Notes
> (https://wiki.documentfoundation.org/images/c/cc/Monster_gltf_model.odp)
> does not match the screencopy from the release notes but match the
> screencopy from the reporter.
> When I click outside the 3D model LO 4.3.1.0.0+ crash without notice.

It would be good if you can open an other bug for that crash.
Comment 5 Tamás Zolnai 2014-08-11 13:43:41 UTC
It's not a bug that the models are not played by default (when open the file). They can be played as movies/sounds.
For wrong default position we already have a bug report:
https://bugs.freedesktop.org/show_bug.cgi?id=81181
The screenshot on the release notes page was created after changed the view of the model.
So I close this bug.

*** This bug has been marked as a duplicate of bug 81181 ***
Comment 6 Tamás Zolnai 2014-08-11 14:41:12 UTC
Just for you information, I uploaded a new version of the monster model which has a better positioning:
https://wiki.documentfoundation.org/images/c/cc/Monster_gltf_model.odp
Comment 7 Jean-Baptiste Faure 2014-08-11 19:41:42 UTC
(In reply to comment #4)
> (In reply to comment #2)
[...]
> > When I click outside the 3D model LO 4.3.1.0.0+ crash without notice.
> 
> It would be good if you can open an other bug for that crash.

done: https://bugs.freedesktop.org/show_bug.cgi?id=82476