Bug Hunting Session
Bug 82136 - Build fails when fetching external packages with libreoffice-4.3.0.4
Summary: Build fails when fetching external packages with libreoffice-4.3.0.4
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: David Tardon
URL:
Whiteboard: target:4.4.0 target:4.3.1
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-04 16:13 UTC by Armin K
Modified: 2014-08-04 19:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
configure output and invocation (25.10 KB, text/plain)
2014-08-04 16:13 UTC, Armin K
Details
make output (53.56 KB, text/x-log)
2014-08-04 16:13 UTC, Armin K
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Armin K 2014-08-04 16:13:28 UTC
Created attachment 104005 [details]
configure output and invocation

When running "make build" on libreoffice-4.3.0.4 release, I get the following error:

Makefile:197: *** fetch__Download_item: libreoffice-dictionaries-4.3.0.4.tar.xz is empty.  Stop.

Issue has also been reported downstream [1].

configure.log, which contains output of ./configure command and the arguments it has been run with is attached. make.log and the actual build error is also attached.

[1] http://wiki.linuxfromscratch.org/blfs/ticket/5311
Comment 1 Armin K 2014-08-04 16:13:50 UTC
Created attachment 104006 [details]
make output
Comment 2 David Tardon 2014-08-04 16:53:02 UTC
Soo, could you show me the patch you apply to Makefile.fetch ?
Comment 3 Armin K 2014-08-04 16:54:43 UTC
I don't apply any patches. Only 2 seds:

sed -e "/gzip -f/d"   \
    -e "s/.1.gz/.1/g" \
    -i bin/distro-install-desktop-integration
sed -e "/distro-install-file-lists/d" -i Makefile.in

chmod +x bin/unpack-sources
Comment 4 David Tardon 2014-08-04 17:02:51 UTC
Yes you do... Because the error tells me that line 197 of your Makefile.fetch contains

    libreoffice-dictionaries-4.3.0.4.tar.xz \

, which most certainly does not come from us.
Comment 5 Armin K 2014-08-04 17:12:49 UTC
Error says "Makefile", not "Makefile.fetch" and "Makefile" is generated by configure.

Makefile.fetch line 197 contains the following:

                $(call fetch_Optional,REVENGE,REVENGE_TARBALL) \

While Makefile line 197 contains the following:

	$(foreach i,$(subst helpcontent2,help,$(GIT_NEEDED_SUBMODULES)),\
		$(call fetch_Download_item,http://download.documentfoundation.org/libreoffice/src/$(shell echo $(gb_LO_VER) | sed -e "s/\([0-9]*\.[0-9]*\.[0-9]*\).*/\1/"),libreoffice-$(i)-$(gb_LO_VER).tar.xz,no-check))
Comment 6 David Tardon 2014-08-04 17:33:02 UTC
That is embarrassing... Anyway, I see what the problem is. It has not been discovered sooner as no distro uses the automatic fetching of tarballs.
Comment 7 Commit Notification 2014-08-04 17:35:35 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=922b03f0818baa65e4c036f58fe7f8c29776b81e

fdo#82136 fix download of submodule tarballs



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Armin K 2014-08-04 17:40:25 UTC
It's downloading fine now. Any chance that this gets included in 4.3.1 release?
Comment 9 David Tardon 2014-08-04 17:43:46 UTC
I submitted the fix for review: https://gerrit.libreoffice.org/#/c/10738/
Comment 10 Commit Notification 2014-08-04 19:05:41 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6cbe7ec6a027aab829e1a800542ec3796ec719ae&h=libreoffice-4-3

fdo#82136 fix download of submodule tarballs


It will be available in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.