Bug 82185 - Protection of Section and Cross-References
Summary: Protection of Section and Cross-References
Status: RESOLVED DUPLICATE of bug 80806
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-05 11:04 UTC by princeneosis
Modified: 2014-10-05 11:49 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
file that reproducts the bug (17.68 KB, application/vnd.oasis.opendocument.text)
2014-08-05 15:34 UTC, princeneosis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description princeneosis 2014-08-05 11:04:39 UTC
Since V 4.3 the documents with a write-protected section cannot be modified even for the cross-reference source. 
This is a regression because with older versions it was possible to protect the whole section except the cross reference text field.
Comment 1 princeneosis 2014-08-05 11:13:30 UTC
In fact the field can still be modified through Shift + Ctrl + F9 but not by clicking it.
Comment 2 sophie 2014-08-05 13:47:03 UTC
Hi, could you provide a document to reproduce your issue. I think it's a duplicate of bug 80806 but want to check first. Thanks Sophie
Comment 3 princeneosis 2014-08-05 15:34:11 UTC
Created attachment 104075 [details]
file that reproducts the bug

The input field is in section 1, wether protected or not this bug actually concerns the fonctionnality of clicking on the input field to modify it.
Comment 4 princeneosis 2014-08-05 15:34:56 UTC
Here is the file, thank you.
Comment 5 Owen Genat (retired) 2014-10-05 11:49:36 UTC
Sophie, I think you are correct. Severity set to normal (prior to close).

*** This bug has been marked as a duplicate of bug 80806 ***