Download it now!
Bug 82223 - GL3D Chart shown on all sheets of Spreadsheet
Summary: GL3D Chart shown on all sheets of Spreadsheet
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 81107
  Show dependency treegraph
 
Reported: 2014-08-06 05:04 UTC by xukai
Modified: 2014-09-10 12:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (96.41 KB, image/png)
2014-08-11 07:09 UTC, xukai
Details
the screenshot after switch sheet (84.98 KB, image/png)
2014-08-11 07:19 UTC, xukai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xukai 2014-08-06 05:04:48 UTC

    
Comment 1 ign_christian 2014-08-06 05:31:19 UTC
Please provide reproducible steps to see the problem. Then change status to UNCONFIRMED
Comment 2 xukai 2014-08-07 07:49:27 UTC
1 create an libreoffice Calc document, contains two sheets.
2 create a chart in Sheet1 , select the chart type : GL3D Bar
3 switch to sheet2, the chart in Sheet1 is not hidden.
Comment 3 ign_christian 2014-08-07 09:21:50 UTC
(In reply to comment #2)
> 3 switch to sheet2, the chart in Sheet1 is not hidden.
I'm sorry I don't understand why it should be hidden?
Comment 4 xukai 2014-08-11 00:57:13 UTC
Other type s of chart should be hidden, because the chart belongs the sheet1, not belong to sheet2
Comment 5 ign_christian 2014-08-11 02:04:28 UTC
(In reply to comment #2)
> 3 switch to sheet2, the chart in Sheet1 is not hidden.
Please give more detailed instruction with that step. Then change status back to UNCONFIRMED
Comment 6 xukai 2014-08-11 07:09:42 UTC
Created attachment 104411 [details]
Screenshot

This screenshot shows how to switch sheet in libreoffice calc
Comment 7 xukai 2014-08-11 07:19:32 UTC
Created attachment 104412 [details]
the screenshot after switch sheet
Comment 8 ign_christian 2014-08-11 07:59:27 UTC
Okay I understood, so Sheet1's chart appear in Sheet2. 

I can't reproduce with LO 4.3.1.1 - Ubuntu 12.04 x86. Perhaps 4.4 only
Comment 9 Bugcruncher 2014-08-16 07:12:01 UTC
Reproducible with Version: 4.4.0.0.alpha0+ Build ID: 0771823d80abadf8e7f2ccc078f3f9e2c277f8a5 TinderBox: Win-x86@42, Branch:master, Time: 2014-08-15_23:19:56
It does not matter in what sheet the chart has been created and in what order sheets have been created, at least a gray (background?) area will be shown on all sheets.
Comment 10 xukai 2014-08-18 02:25:57 UTC
But,Other type s of chart should be hidden.only the type:gl3d is not hidden.
(In reply to comment #9)
> Reproducible with Version: 4.4.0.0.alpha0+ Build ID:
> 0771823d80abadf8e7f2ccc078f3f9e2c277f8a5 TinderBox: Win-x86@42,
> Branch:master, Time: 2014-08-15_23:19:56
> It does not matter in what sheet the chart has been created and in what
> order sheets have been created, at least a gray (background?) area will be
> shown on all sheets.
Comment 11 Jan Holesovsky 2014-09-10 12:48:13 UTC
The branch to make this work was merged to master, should be fixed now.  If there are problems, best to handle in follow-up bug reports.