Bug 82227 - Do not replace fonts silently
Summary: Do not replace fonts silently
Status: RESOLVED DUPLICATE of bug 78186
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-06 06:49 UTC by Ulrich Windl
Modified: 2014-08-06 11:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Windl 2014-08-06 06:49:39 UTC
When migrating to a new system or OS, you'll have to install all the fonts that your documents use on the new system. However LibreOffice does not help you here:

1) When a font is missing, LibreOffice uses a different font (Courier?) _without_ any message showing up.

2) There is no built-in "list used fonts" or "show current font replacements" (fonts that LibreOffice silently replaced by other fonts)

So I suggest:
1) Implement something like a LibreOffice "Console" that can show informational messages or warnings when the user wants to look for these (would also help debugging and problem reporting, I guess)

2) Indicate if some fonts of a document opened are missing

3) Allow the user to list all fonts a document requested (I'm not using the word "uses" here, as the fonts could have been replaced already)

4) If 3) would also indicate missing or substituted fonts, it would be great.

5) You can print the styles your document uses (that function is hidden extremely well). I think the fonts a document uses are also a part of its style and should be included as well, possibly also with all sizes of the font being used.
Comment 1 Cor Nouws 2014-08-06 10:24:33 UTC
Hi Ulrich,

Not disagreeing with any idea for improvement, but you know that on the tab Font from the dialog Font it _is_ indicated (above the lower box showing the result with the font) if a specific font is not available?

Cheers,
Cor
Comment 2 Maxim Monastirsky 2014-08-06 10:44:16 UTC
Very similar to bug 78186.

*** This bug has been marked as a duplicate of bug 78186 ***
Comment 3 Ulrich Windl 2014-08-06 11:48:36 UTC
(In reply to comment #1)
When opening a document in read-only mode that information is not available, right?
Comment 4 Ulrich Windl 2014-08-06 11:51:46 UTC
(In reply to comment #2)
Actually I think bug 78186 is only a subset of my proposals.