Bug 82256 - Text frames from odd page header/footer are duplicated on even page
Summary: Text frames from odd page header/footer are duplicated on even page
Status: RESOLVED DUPLICATE of bug 82165
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: odf
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-08-06 16:58 UTC by Justin L
Modified: 2014-12-31 06:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
If this document is opened in LO 4.0, it will only show ONE number in the even page footer. If this document is opened in LO 4.2, it will show TWO numbers/frames in the even page footer. (27.66 KB, application/vnd.oasis.opendocument.text)
2014-08-06 16:58 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin L 2014-08-06 16:58:16 UTC
Created attachment 104162 [details]
If this document is opened in LO 4.0, it will only show ONE number in the even page footer.   If this document is opened in LO 4.2, it will show TWO numbers/frames in the even page footer.

LibreOffice creates a NEW frame upon loading a document that has a text frame in the header or footer of a page with different odd & even pages. The text frame of an odd-page footer is duplicated and added to the even page footer.


Steps to re-create the problem.
1) on a two+ page document, format page - turn on footer, uncheck (turn off) same content left/right
2.) Insert Frame into the footer on the first (odd number) page.  Give the frame a name so that you can identify it in View-Navigator-TextFrames.
3.) save and close.  Upon reopening the document, you will see a second Frame has been automatically created, and displays on the second (even number) page footer.


Notes:
-the same is true for headers
-not a bug in 4.0.  Bug is present in 4.2.  Likely first broken in 4.0.5 or 4.0.6.
Comment 1 Michael Stahl (CIB) 2014-08-12 16:54:19 UTC
fixed by commit 555c988f3b896e16afc7bdd1bd98e48229599637

*** This bug has been marked as a duplicate of bug 82165 ***
Comment 2 Antoine POURCHEZ 2014-10-13 16:15:28 UTC
Will you integrate this fixed into the 4.2.x branch? If so, what version?