Bug 82270 - UI: Writer crashes/closes when using navigator after editing a comment
Summary: UI: Writer crashes/closes when using navigator after editing a comment
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: Other Linux (All)
: medium normal
Assignee: Caolán McNamara
Whiteboard: BSA target:4.4.0 target:4.3.4
Keywords: haveBacktrace
Depends on:
Reported: 2014-08-06 23:49 UTC by Lucas Capalbo
Modified: 2014-10-11 17:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

Example file to reproduce this bug (26.89 KB, application/vnd.oasis.opendocument.text)
2014-08-07 12:40 UTC, Lucas Capalbo
backtrace - Segmentation fault (13.89 KB, text/x-log)
2014-08-09 17:16 UTC, Lucas Capalbo

Note You need to log in before you can comment on or make changes to this bug.
Description Lucas Capalbo 2014-08-06 23:49:25 UTC
Problem description: 
Writer closes when clicking on the navigator window/sidebar after editing a comment.

Steps to reproduce:
1. Open a document with comments
2. Either open the navigator window (F5) or use the sidebar on navigator tab
3. Open the comments sections. double click one to jump
4. Edit the comment (I added a text at the beginning)
5. In the navigator, click on Titles o some other section

Current behavior:
Writer crashes/closes abruptly

Expected behavior:
1 - The comment should be refreshed in navigator tree
2 - If double clicked some title/section in step 5, current focus should jump to that location

Tested con LO Compilation 430m0(Build:4) - Ubuntu 14.04 through PPA (https://launchpad.net/~libreoffice/+archive/libreoffice-4-3)
Operating System: Ubuntu
Version: release
Comment 1 Joel Madero 2014-08-07 00:16:46 UTC
Please attach a simple test case - I just tested with a fresh document and could not reproduce.

Setting as NEEDINFO - once you attach the document set the bug to UNCONFIRMED. Thanks!
Comment 2 Lucas Capalbo 2014-08-07 12:40:29 UTC
Created attachment 104225 [details]
Example file to reproduce this bug

I created this file which allowed me to reproduce the bug following the steps. Tried to run from console but no error output was written
Comment 3 Julien Nabet 2014-08-09 05:32:08 UTC
On pc Debian x86-64 with 4.3 sources updated some days ago, I don't reproduce this.

Would you have some time to give a try with a 4.3 daily build? (see http://dev-builds.libreoffice.org/daily/libreoffice-4-3/)
You may also reset your LO directory profile for the test, see https://wiki.documentfoundation.org/UserProfile#GNU.2FLinux
Comment 4 Lucas Capalbo 2014-08-09 13:56:16 UTC
I've tried removing my profile and it crashed too.
Then tried with /daily/libreoffice-4-3/Linux-rpm_deb-x86_64@46-TDF/2014-08-09_02.48.30 and a clean profile. It worked fine on my first test, but then it started to crash again, always doing the same steps stated in my report.
Ubuntu has a crash report tool, apport, that detected something went wrong and allowed me to send a crash report. I've sent it but I'm not sure exactly were it went as to share a link, so I uploaded that to my google drive. I think it includes an stacktrace and some memory dump, I hope it's useful.

daily report: https://drive.google.com/file/d/0B9FSktB6hAQ-RllPOXJmTWNvR0E/edit?usp=sharing
PPA report: https://drive.google.com/file/d/0B9FSktB6hAQ-ck9iY1IwN3NySFk/edit?usp=sharing

Thank you both for your time!
Comment 5 Julien Nabet 2014-08-09 14:45:17 UTC
Thank you for your feedback, I think a backtrace retrieved with this way:
might be more useful, could you give it a try?
Comment 6 Lucas Capalbo 2014-08-09 17:16:00 UTC
Created attachment 104352 [details]
backtrace - Segmentation fault
Comment 7 Julien Nabet 2014-08-09 18:20:20 UTC
Thank you for your feedback, we can now put this bugtracker to NEW with this backtrace.
Comment 8 Caolán McNamara 2014-10-09 12:35:04 UTC
You've got to do it sort of fast, otherwise the timer kicks in and updates the navigator with the new comment text. So it has to be edited, and then click in the headings before the navigator has updated the entry for the comment.