Download it now!
Bug 82295 - EDITING: functions do not recalculate after undo
Summary: EDITING: functions do not recalculate after undo
Status: RESOLVED DUPLICATE of bug 80846
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-07 13:49 UTC by edleijten
Modified: 2014-08-08 08:13 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description edleijten 2014-08-07 13:49:52 UTC
Problem description: 
When deleting a value of a cell that is used in a function, the function result is correctly updated. However when undo is applied, the value in the cell is restored but the function result is not updated. Pressing F9 to recalculate does not change the result, only editing the function by removing and re-typing one character gives correct results again.
The behaviour is correct when a cell is cut, but not when its contents are deleted...


Steps to reproduce:
1. create a spreadsheet with values 1 to 10 in a row
2. add a max() function (e.g. =max(A1:A10) ). Works also with min() and average() functions, I have not tested other functions.
3. delete the value from the cell containing value 10 (cell A10)
4. the result of the max() function is now correctly recalculated to "9"
5. now press undo / CTRL+Z
6. the result of the max() function remains at "9" while it should be 10.

Current behavior:
Function is not recalculated after pressing undo following a delete action.

Expected behavior:
Function(s) should recalculate
              
Operating System: Windows 7
Version: 4.3.0.4 release
Comment 1 ign_christian 2014-08-08 08:13:51 UTC
Hi.. It's fixed in 4.3.1

*** This bug has been marked as a duplicate of bug 80846 ***