Bug 82316 - Dialog box wrong size query editor table relationships (regression 4.3.0.4?)
Summary: Dialog box wrong size query editor table relationships (regression 4.3.0.4?)
Status: RESOLVED DUPLICATE of bug 83501
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-08 03:38 UTC by Doug
Modified: 2015-02-10 07:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
demonstration document (3.89 KB, application/vnd.oasis.opendocument.database)
2014-08-08 22:22 UTC, Doug
Details
dialog box correctly formatted (Windows 7) (17.15 KB, image/png)
2014-08-09 12:28 UTC, Doug
Details
dialog box after changing join type, buttons out of view (Windows 7) (18.11 KB, image/png)
2014-08-09 12:29 UTC, Doug
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Doug 2014-08-08 03:38:20 UTC
In Base, edit query, add some tables, create a join between the tables.  Right mouse click on the line representing the relationship, the dialog box is ok size to show control buttons at bottom (OK, Cancel).  However, if join relationship is changed to one with a longer description (e.g., LEFT JOIN) the control buttons are pushed outside the visible area in the dialog box.  Cannot press "OK" without resizing dialog box.

This may be regression for 4.3.0.4

In prior release I don't think there was any problem with the control buttons being pushed outside the visible area.
Comment 1 Joel Madero 2014-08-08 05:00:35 UTC
Please provide clear steps and a sample (simple) file to test on. Marking as NEEDINFO - once you do the above the bug to UNCONFIRMED.

@Doug - I'm seeing a lot of bugs reported by you and that's awesome but please keep in mind how thin our QA team is. It's ALWAYS beneficial to include clear and simple steps as well as a sample document. Also keep in mind that database is one of our least used components so the QA team is less familiar with the component and thus it makes it even more crucial to have repro steps and an attachment.

Thanks for understanding.
Comment 2 Doug 2014-08-08 22:22:23 UTC
Created attachment 104320 [details]
demonstration document


here is a test document to demonstrate this bug.  I noted in making it that the bug is *not* present on LO Base 4.1.6.2/Linux.  Bug repeatedly encountered in LO Base 4.3.0.4/Windows7.

Per bug report:

1. open Query1 for edit
2. right mouse click on line relationship between two tables in query builder, click edit
3 this dialog box is the problem.  LO provides text explanation for default inner_join that is shorter in length than explanation for LEFT JOIN or RIGHT JOIN, especially where as in test document there are long table names.
4. in Windows 7 or LO 4.3.0.4 or both, the control buttons are at bottom rather than to right in LO 4.1.6.2/Linux.

As a result, the long explanation that is inserted in dialog box when selecting LEFT JOIN or RIGHT JOIN pushes the dialog box buttons out of view and the user has to find them by manually resizing the dialog box.

(I originally posted this under the wrong bug, sorry)
Comment 3 Doug 2014-08-09 12:28:00 UTC
Created attachment 104340 [details]
dialog box correctly formatted (Windows 7)
Comment 4 Doug 2014-08-09 12:29:14 UTC
Created attachment 104341 [details]
dialog box after changing join type, buttons out of view (Windows 7)
Comment 5 Alex Thurgood 2014-10-19 17:15:22 UTC
Probably UI rework of Base dialogs, where window does not correctly resize
Comment 6 Alex Thurgood 2014-10-19 17:20:24 UTC
Can not reproduce on master 440 alpha OSX 10.10 - the Join dialog window coorectly displays full length of table names at top and buttons at bottom
Comment 7 Alex Thurgood 2014-10-19 17:22:03 UTC
Can't reproduce on LO 4322 either.
Comment 8 Alex Thurgood 2014-10-20 07:09:23 UTC
Possibly Windows only bug ?

@Doug : please test with LO 4322 with clean LO profile and report back
Comment 9 Buovjaga 2014-11-27 11:45:00 UTC
All is ok for me. It seems all the work with dialogs has changed the appearance (definitely completely different from the screenshots).
I recommend that the reporter test with 4.4 beta http://www.libreoffice.org/download/pre-releases/

Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.

Win 7 64-bit Version: 4.5.0.0.alpha0+
Build ID: b144f0ac8695dd62a2053b4e88212d0b109c9a41
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-11-25_00:14:54

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: 6b219f012edbe069c461f4e0746898e33fa1dd49
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-11-25_21:56:46
Comment 10 Alex Thurgood 2015-01-03 17:39:26 UTC
Adding self to CC if not already on
Comment 11 Julien Nabet 2015-02-08 22:18:32 UTC
On pc Debian x86-64 with master sources updated yesterday or with LO Debian package 4.3.3, I don't reproduce this.
Let's put this one to WFM.

Doug: if you can reproduce this with a recent LO version (last stable one is 4.3.5), don't hesitate to reopen this tracker.
Comment 12 Doug 2015-02-09 01:35:56 UTC
Looks great Windows 7 LO 4.3.5.2.  Thx.
Comment 13 Joel Madero 2015-02-09 02:25:09 UTC
WFM is appropriate status when we don't know what commit fixed the issue. Thanks!
Comment 14 Adolfo Jayme 2015-02-10 07:48:42 UTC
We actually know the commit fixing this issue. See duplicate.

*** This bug has been marked as a duplicate of bug 83501 ***