Bug Hunting Session
Bug 82398 - EDITING: "Text to Columns" not applied to selected cells after change 'Format Cells'
Summary: EDITING: "Text to Columns" not applied to selected cells after change 'Format...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:6.1.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-09 20:45 UTC by Alastair Munro
Modified: 2018-05-07 04:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alastair Munro 2014-08-09 20:45:05 UTC
Problem description: 

Steps to reproduce:
1. Select a range of cells downwards in same column
2. Right click->Format->Numbers. Change to format required (either currency or date).
3. Range of cells still selected.
4. Data->Text to columns. Then Ok.


Current behavior: Only first cell is converted.

Expected behavior: All selected cells should be converted.

Work around: reselect the cell range. Data->Text to columns. Then Ok. Now it works. Irritating that I have to re select the cell range.

              
Operating System: Ubuntu
Version: 4.2.4.2 release
Comment 1 ign_christian 2014-08-10 10:40:39 UTC
Reproduced with 4.2.6.2, 4.0.6.2, 3.3.0.4 - Ubuntu 12.04 x86

Not reproduced with LO 4.3.1.1

Waiting confirmation from dev if fix will backported to 4.2.7
Comment 2 ign_christian 2014-08-10 10:42:24 UTC
Still reproduced in 4.2.7.0.0+ Time: 2014-07-30_13:16:10
Comment 3 Joel Madero 2014-09-04 08:29:18 UTC
I am closing this as WFM - it would take some effort from multiple people to find the patch, review the patch, and backport the patch. While the OP says it's "quite annoying" the workaround is quite straightforward. 4.3 is available and the problem is resolved.
Comment 4 Alastair Munro 2014-09-04 09:51:38 UTC
Thanks fine. I added the LibreOffice apt repos and am using 4.3, and can confirm the issue does not exist in this release. Shame the ubuntu versions are out of date. Thanks for looking into it.
Comment 5 Joel Madero 2014-09-04 13:22:33 UTC
FWIW - Ubuntu release is pretty much always "out of date" (or it is as soon as a new "fresh" release comes out) and this is by design - they have a pretty strict regression policy so if you want "latest and greatest" you have to get the ppa.
Comment 6 Commit Notification 2018-05-07 04:36:56 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b5fe54fa3cfeaa9208b9e04e7deb7db9d43683e7

uitest forbug tdf#82398

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.