Bug 82509 - damaged files with PDF export - fonts are not correct
Summary: damaged files with PDF export - fonts are not correct
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-08-12 12:03 UTC by Ingo Belka
Modified: 2015-12-15 10:49 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
original LO-file (36.66 KB, application/vnd.oasis.opendocument.text)
2014-08-12 12:03 UTC, Ingo Belka
Details
PDF file coming from LO (27.87 KB, application/pdf)
2014-08-12 12:04 UTC, Ingo Belka
Details
image how it looks in LO (518.69 KB, image/jpeg)
2014-08-12 12:04 UTC, Ingo Belka
Details
image how it looks in FoxitReader (385.85 KB, image/jpeg)
2014-08-12 12:05 UTC, Ingo Belka
Details
image how it looks in AdobeReader (389.91 KB, image/jpeg)
2014-08-12 12:05 UTC, Ingo Belka
Details
image how it looks in GhostView (314.25 KB, image/jpeg)
2014-08-12 12:06 UTC, Ingo Belka
Details
PDF file coming from pdfforge's PDF-Creator (39.17 KB, application/pdf)
2014-08-12 12:11 UTC, Ingo Belka
Details
LO 4.2.6 - properties of the exported pdf - ok (97.03 KB, image/jpeg)
2014-09-03 09:47 UTC, Ingo Belka
Details
LO 4.3.x - properties of the exported pdf - not ok (48.62 KB, image/jpeg)
2014-09-03 10:02 UTC, Ingo Belka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ingo Belka 2014-08-12 12:03:21 UTC
Created attachment 104493 [details]
original LO-file

The via PDF export generated files are damaged. The are looking totally different in different viewers. German umlauts are lost in AdobeReader and GhostView, the fonts are mostly not the right ones. 

I did nothing els as usually:

1. open a file
2. export as pdf

View with FoxitReader, AdobeReader and GhostView - each gives another result.
Comment 1 Ingo Belka 2014-08-12 12:04:06 UTC
Created attachment 104494 [details]
PDF file coming from LO
Comment 2 Ingo Belka 2014-08-12 12:04:52 UTC
Created attachment 104495 [details]
image how it looks in LO
Comment 3 Ingo Belka 2014-08-12 12:05:25 UTC
Created attachment 104496 [details]
image how it looks in FoxitReader
Comment 4 Ingo Belka 2014-08-12 12:05:58 UTC
Created attachment 104497 [details]
image how it looks in AdobeReader
Comment 5 Ingo Belka 2014-08-12 12:06:35 UTC
Created attachment 104498 [details]
image how it looks in GhostView
Comment 6 Ingo Belka 2014-08-12 12:11:23 UTC
Created attachment 104499 [details]
PDF file coming from pdfforge's PDF-Creator

http://www.pdfforge.org/pdfcreator/download
Comment 7 Adolfo Jayme 2014-09-01 03:13:53 UTC
It could be possible that the fonts you’re using don’t have the “Embeddable” permission. https://www.microsoft.com/typography/web/embedding/weft/weft14.htm

Does the problem happen with other fonts?
Comment 8 Ingo Belka 2014-09-03 08:27:10 UTC
It could be possible, indeed. With other fonts I get an expected result.

The only thing is, that LO 4.2.6 doesn't make these problems, LO 4.3.X does. And I tested on WinXP and Win7. It must be a problem while exporting to PDF.

And I can't use other fonts because of company corporate design instructions.

BTW the tool of Microsoft doesn't seem to work with Windows 7.
Comment 9 Ingo Belka 2014-09-03 09:44:55 UTC
I attached two picture

LO 4.2.6 can export right
LO 4.3.x can not export right
Comment 10 Ingo Belka 2014-09-03 09:47:02 UTC
Created attachment 105671 [details]
LO 4.2.6 - properties of the exported pdf  - ok

LO 4.2.6 can export right
Comment 11 Ingo Belka 2014-09-03 10:02:39 UTC
Created attachment 105672 [details]
LO 4.3.x - properties of the exported pdf - not ok

LO 4.3.x doesn't export right
Comment 12 Ingo Belka 2015-02-02 07:20:56 UTC
Hello,

OK I tried LO 4.4.0.3 and so annoying but this bug still is present. That's so sad - the same behaviour as 4.3.x. 

What can I do to push this to the developers attention?
Comment 13 Ingo Belka 2015-09-23 05:56:06 UTC
My further search for a reason of this behaviour led me to check the font files, which were installed on my system. So I found, that I had installed several font files with different file names, but in fact some of them were identically fonts. I deleted the more or less "duplicates" and now I do have no more trouble with the PDF-Export.

I'm hoping that helps!
Comment 14 Adolfo Jayme 2015-09-24 23:32:09 UTC
Thank you for your feedback! Do you agree in closing this report with the “WORKSFORME” status or shall we consider this an enhancement request for duplicate-font handling from now on?
Comment 15 Ingo Belka 2015-09-25 05:23:19 UTC
If one know about this behaviour, then it's easy to prevent LO form doing damaged PDF files. I'm not really familiar with closing bug requests. I would appreciate, if you decide how to proceed further. Each decision you make is better, then I could do.
Comment 16 Adolfo Jayme 2015-09-26 00:16:58 UTC
On a second thought, let’s close this report to avoid clutter. We’ll handle the enhancement I mentioned in a separate bug report, as it will need further discussion.

Thanks again, Ingo!
Comment 17 Robinson Tryon (qubit) 2015-12-15 10:49:16 UTC
Migrating Whiteboard tags to Keywords: (regression)
[NinjaEdit]