Download it now!
Bug 82531 - FORMATTING: text shifted in PPT vs. PPTX
Summary: FORMATTING: text shifted in PPT vs. PPTX
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-12 23:24 UTC by Samuel Sieb
Modified: 2019-12-03 21:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
PPT version (134.50 KB, application/vnd.ms-powerpoint)
2014-08-12 23:24 UTC, Samuel Sieb
Details
PPTX version (51.92 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2014-08-12 23:25 UTC, Samuel Sieb
Details
screenshot of PowerPoint (44.85 KB, image/png)
2014-08-12 23:25 UTC, Samuel Sieb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Sieb 2014-08-12 23:24:40 UTC
Created attachment 104530 [details]
PPT version

Text is shifted when the file format is PPT.

I opened the file in Microsoft Office and removed everything except the one text field.  I saved it in both pptx and ppt formats.  LibreOffice shows the pptx correctly, but when opened from the ppt file, the text is shifted down.  Strangely, the preview thumbnail in Nautilus shows both the same.

I will include both versions of the file and a screenshot from PowerPoint.  Note that there were two blanks lines ahead of the visible text, but I put numbers in there to make it more clear.

I tested it with LibreOffice 4.3.1.1 as well and it was the same there.
Comment 1 Samuel Sieb 2014-08-12 23:25:15 UTC
Created attachment 104531 [details]
PPTX version
Comment 2 Samuel Sieb 2014-08-12 23:25:44 UTC
Created attachment 104532 [details]
screenshot of PowerPoint
Comment 3 Robinson Tryon (qubit) 2014-08-16 00:11:26 UTC
CONFIRMED on LO 4.3.1.1 + Ubuntu 12.04

(In reply to comment #0)
> I opened the file in Microsoft Office and removed everything except the one
> text field.  I saved it in both pptx and ppt formats.  LibreOffice shows the
> pptx correctly, but when opened from the ppt file, the text is shifted down.
> Strangely, the preview thumbnail in Nautilus shows both the same.

Using the MS-Office screenshot as a baseline, the PPTX does appear to be more faithful to the original than the PPT. Interestingly, if you click on the header box in the PPT (e.g. so that you could edit it), it moves up to the expected position. Unfortunately, the header moves back down after you exit from the box.

Status -> NEW
Comment 4 tommy27 2015-08-17 17:14:46 UTC
I confirm bug under Windows 8.1 x64 using LibO 4.4.5.1 and 5.1.0.0.alpha1+
Build ID: 7d3fa6bae9f7a755eb2d0ca24bf1afd5f3646bb7
TinderBox: Win-x86@39, Branch:master, Time: 2015-08-09_08:38:08
Locale: it-IT (it_IT)
Comment 5 QA Administrators 2016-09-20 10:26:05 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2019-12-03 14:18:58 UTC Comment hidden (obsolete)
Comment 7 Samuel Sieb 2019-12-03 19:51:08 UTC
It has been a really long time since I've looked at this so I don't remember exactly what the issue was.  However, since both the PPT and PPTX loaded in a current libreoffice match each other and the screen shot, I'll consider this fixed.
Comment 8 Timur 2019-12-03 21:29:53 UTC
Thanks.
We call it WorksForMe if commit is not known.