Download it now!
Bug 82547 - Main drop down menu freezes libreoffice and whole system
Summary: Main drop down menu freezes libreoffice and whole system
Status: RESOLVED DUPLICATE of bug 89394
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-13 08:16 UTC by Lee
Modified: 2016-05-11 08:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lee 2014-08-13 08:16:13 UTC
Yesterday worked round a system freeze problem on libreoffice

system: xubuntu 14.04 (all patches/updates applied) x64
graphics: amd (tried 2 different cards cards)
processor: core 2 duo (dell 745)
ram: 3gb

Cause: seems to be recent documents list.
Temp Resolution:  clear the recent documents list (did via an extension)

Other Info: most of recent documents located on samba over a vpn, vpn was active and responsive. (openvpn xubuntu stock)

Libreoffice versions tested:  4.2 (xubuntu repo) and 4.3 from the fresh ppa.


Description:

Open a libreoffice app (i tried calc and writer), do some typing on the doc or in a  cell, all seems fine.

As soon as you click a menu item be it Help, Tools, Edit or File etc, the system locks / freezes for a long period of time (maybe a minute or more).  You cannot tab between applications, or move between apps using the mouse.  Mouse pointer does move around the screen.

I recreated with a terminal visible on half the screen and top running, load goes high (2) but the cpu use is low, memory looks ok and io wait blips maybe to 0.5 but not constant.

The system recovers after a period of time (say a minute, sometimes longer), and the menu appears, but as soon as you click either a menu item (or one with sub menu) or another main menu the process repeats.

My efforts to find a resolution included changing the graphics card and upgrading from the stock 4.2 libreoffice supplied with xubuntu to 4.3 from the ppa.

It was resolved using an addon/extension (name elludes me) which clears the recent documents list. Performance then returned to normal.

The system has been working fine since it was installed in May 2014 and has always stored its documents on samba over the vpn. It is used most days for either calc or writer.

VPN performance was fine and tested.
Comment 1 Buovjaga 2014-11-09 19:02:06 UTC
I have to change this to UNCONFIRMED, because we need someone to reproduce the problem before setting to NEW.
Comment 2 Oyvind 2014-12-10 08:16:26 UTC
I can observe the same symptoms on my system:

System: Ubuntu 14.04.1, x64, up-to-date
Processor: Intel Xeon E3-1275 v3
RAM: 32GB

LibreOffice version: 4.2.7.2

Most of the recent documents were located on a Samba server (mounted with mount.cifs, not using GVFS).  In my case the file server is accessed directly over local gigabit ethernet, not using VPN.

I had a small, simple document open in Writer (5-6 pages, almost only regular text), and when jumping around the document there was very noticeable stuttering.  Each pause was well under a second long, but it happened regularly enough (roughly every 5-10 seconds) that it was quite unpleasant to try working.

When i fired up Wireshark, I observed SMB traffic corresponding to the stuttering/pauses.  The packet capture showed that all the documents in the Recent Documents list were accessed when I jumped around in the open document (page up / page down; no editing or saving/loading).  With 25 recent documents and each document being 5-10 levels deep into a directory structure, that's a lot of networked stat calls.

If I let Writer sit still with no activity, there was no SMB traffic.

Setting the Recent Documents list size to 0 removed the stuttering and the SMB traffic.

Is it necessary for LibreOffice to access all the Recent Documents files during regular document editing?  If there is a good reason, can it be made properly asynchronous?

Marking this NEW again.  Thanks for looking into this; I would like to be able to enable recent documents again.
Comment 3 Aron Budea 2016-05-11 08:55:41 UTC
This seems to be a duplicate of bug 89394.

*** This bug has been marked as a duplicate of bug 89394 ***