Download it now!
Bug 82618 - Calc crashes when Tools > Solver is clicked on
Summary: Calc crashes when Tools > Solver is clicked on
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Solver
  Show dependency treegraph
 
Reported: 2014-08-14 13:42 UTC by invisible18
Modified: 2018-06-01 17:08 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description invisible18 2014-08-14 13:42:47 UTC
Error report is below:

Can not activate the factory for com.sun.star.comp.Calc.NLPSolver.DEPSSolverImpl because java.lang.ClassCastException: sun.net.www.protocol.file.FileURLConnection cannot be cast to java.net.JarURLConnection


Thank you.
Comment 1 sophie 2014-08-14 14:12:41 UTC
Hi, I don't reproduce with version 4.3.0.4 Ubuntu 14.04 x64. Sophie
Comment 2 Julien Nabet 2014-08-14 15:32:34 UTC
What's the result of:
java -version
?
Comment 3 Julien Nabet 2014-08-14 15:33:54 UTC
Also, did you uninstall Java version recently?
For the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#GNU.2FLinux) and give it a new try? (It'll force LO to detect your Java version)
Comment 4 Ferry Toth 2014-08-22 11:58:25 UTC
I have the same.

LibO: 4.3.0.4 (Ubuntu PPA)
Kubuntu 14.04 amd64
Java:
java version "1.7.0_65"
OpenJDK Runtime Environment (IcedTea 2.5.1) (7u65-2.5.1-4ubuntu1~0.14.04.1)
OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)
Comment 5 Ferry Toth 2014-08-22 12:07:33 UTC
And indeed: 
mv .config/libreoffice .config/libreoffice.bak

prevents the crash.

So, how do I keep my settings except the one causing the crash.

Ferry
Comment 6 Julien Nabet 2014-08-22 12:16:19 UTC
Ferry: if you've got no confidential/private part in your profile, you may zip it and attach it to the bugtracker by using this link:
https://bugs.freedesktop.org/attachment.cgi?bugid=82618&action=enter

Or you can test directory by directory by using this:
https://bugs.freedesktop.org/attachment.cgi?bugid=82618&action=enter
I mean you can start with "brand new LO profile" + "your autocorr directory"
if ok, add replace another directory from brand new LO profile by yours and so on until you find the culprit.

Also: you can start with "registrymodifications.xcu". Quite often this specific file is culprit. If it's the case, just attach this file instead of the whole directory.
Comment 7 Ferry Toth 2014-09-13 20:58:24 UTC
Just deleting registrymodifications.xcu does not help.

I have not idea if there is any confidential/private part in the profile.

It is 353MB in size in 3199 files. WTF.

I have reproduced the problem on another computer as well.
Comment 8 Jean-Baptiste Faure 2014-09-14 09:09:18 UTC
Did you try to install or reinstall the package libreoffice-nlpsolver ?

Best regards. JBF
Comment 9 Ferry Toth 2014-09-14 16:18:04 UTC
No, currently I'm running LibO from the Ubuntu ppa 4.3.1~rc2-0ubuntu1~trusty1

It get's reïnstalled with every bump of the ppa.

nlpsolver is version 0.9~beta1-9ubuntu1.

I never realized this never got updated. I will try that now.
Comment 10 Ferry Toth 2014-09-14 16:25:37 UTC
Ah, interesting.

I removed the nlp package, then opened LO to verify it was actually removed from the extensions and the menu, then closed LO.

Then reinstalled the nlp package. Opened LO again.

The solver entry is now again in the menu, however, the extensions list shows: Error: The status of this extension is unknown (translated back from -NL).

But running the solver now works without crashing.
Comment 11 Jean-Baptiste Faure 2014-09-14 19:18:52 UTC
Thank you for your answer. I'll close this bug as WorksForMe. Feel free to reopen if needed.

Best regards. JBF
Comment 12 invisible18 2014-12-24 14:58:14 UTC
I have since then upgraded LibreOffice and the problem with the NLP Solver in Calc no longer exists.

Thank you for your assistance.

Keep up the great work.
Comment 13 Kruno 2017-09-01 08:26:54 UTC
Just hit this in LibreOffice 5.3.6:

Build ID: 686f202eff87ef707079aeb7f485847613344eb7
CPU Threads: 2; OS Version: Linux 4.9; UI Render: default; VCL: gtk2; Layout Engine: new; 
Locale: hr-HR (hr_HR.utf8); Calc: group

Tools → Options → Advanced shows Oracle Corporation 1.8.0_141

Deleting user profile is not solving the problem.
Comment 14 Jean-Baptiste Faure 2017-09-02 07:31:53 UTC
(In reply to Kruno from comment #13)
> Just hit this in LibreOffice 5.3.6:

Did you try to apply comment #8 ?

Best regards. JBF
Comment 15 Julien Nabet 2017-09-06 09:57:02 UTC
Following Jean-Baptiste question, let's put this one to NEEDINFO.
Comment 16 QA Administrators 2018-05-02 15:47:00 UTC Comment hidden (obsolete)
Comment 17 QA Administrators 2018-05-30 16:47:47 UTC Comment hidden (obsolete)
Comment 18 Jean-Baptiste Faure 2018-06-01 17:08:15 UTC
set status back to WorksForMe.

Best regards. JBF