Bug 82652 - UI: With new User Profile: Translation for Area Gradient names lost
Summary: UI: With new User Profile: Translation for Area Gradient names lost
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: BSA target:4.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-15 06:53 UTC by Bugcruncher
Modified: 2014-09-03 18:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot from (94.78 KB, image/png)
2014-08-15 06:53 UTC, Bugcruncher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bugcruncher 2014-08-15 06:53:51 UTC
Created attachment 104656 [details]
Screenshot from

Problem description: 
With my old user profile with very long history back to the beginnings of OO Names of the Area Gradients change with UI language. Gradient set shown in a newly created User Profile shows English color names independent from UI language.

Steps to reproduce:
1. Open your Localized (French or German UI language) 
   LibreOffice
2. Launch Draw  ► Insert Shape  ► In Format Toolbar click
   "Area"  ► Gradients (Tab)
   » With a little luck you will see the names for the
     gradients in your language
3. Exit Libreoffice
4. In "C:\Users\user\AppData\Roaming\LibreOffice" 
   (or the folder where the User Profile for your installation
    might be) rename the folder with name "4" containing
    your user profile to "4_bak" or so.
5. Do again steps 1 ... 2 (and change UI language back to
   French / German / whatever except English)

Current behavior: Now Gradients will show English names
Expected behavior: Gradient names in UI language

I did not test with what Version that problem really started.

May be the problem is mor simple "No translation for area gradients"? The gradients set I see with new profile is a different one from the one I see with my old user profile 8what might be a separate issue)
              
Operating System: Windows 7
Version: 4.2.5.2 release
Comment 1 Adolfo Jayme 2014-08-15 10:30:08 UTC
Thank you for your bug report. These new gradients are indeed untranslatable.
Comment 2 Julien Nabet 2014-08-15 13:33:51 UTC
Adolfo: Looking at git history of extras/source/palettes/standard.sog, I wonder how the translation could work. Anyway, any idea how to fix this?
Comment 3 Andras Timar 2014-08-28 15:21:47 UTC
(In reply to comment #2)
> Adolfo: Looking at git history of extras/source/palettes/standard.sog, I
> wonder how the translation could work. Anyway, any idea how to fix this?

svx/source/dialog/sdstring.src must be updated.
Comment 4 Julien Nabet 2014-08-29 20:06:02 UTC
Andras: I don't understand your last comment since, for example, I don't find "Grison" in svx/source/dialog/sdstring.src
Moreover, there are a lot of expressions with "do not translate", should we remove them and change them like for example:
    351 /* do not translate */
    352 String RID_SVXSTR_COLOR_BLACK_DEF
    353 {
    354     Text = "Black" ;
    355 };

    351 
    352 String RID_SVXSTR_COLOR_BLACK_DEF
    353 {
    354     Text[ en-US ] = "Black" ;
    355 };

?
Comment 5 Commit Notification 2014-09-03 18:44:04 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=927a869b9ac0e8a36de08f160a0c9a42452ef3aa

fdo#82652 add new gradient names to translatable resource



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.