Download it now!
Bug 82654 - FILESAVE, FILEOPEN: style name prefixed with "Excel Built-in"
Summary: FILESAVE, FILEOPEN: style name prefixed with "Excel Built-in"
Status: RESOLVED DUPLICATE of bug 123428
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: XLS-Limitations XLSX-Limitations Calc-Styles
  Show dependency treegraph
 
Reported: 2014-08-15 08:08 UTC by Markus
Modified: 2019-03-23 16:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Spreadsheet showing the prefixing of the style name (4.41 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-08-15 08:08 UTC, Markus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus 2014-08-15 08:08:48 UTC
Created attachment 104658 [details]
Spreadsheet showing the prefixing of the style name

Hello,

When saving a spreadsheet to xlsx and then reopening it, the name of custom styles are prefixed with "Excel Built-in".


Steps to reproduce:

1) Create a new Spreadsheet
2) Create a new style (e.g. via "New Style from Selection), name it "MyStyle"
3) Save the document as xlxx
4) Close the Document
5) Open the document again
=> Now the Style appears in the list of styles as "Excel Built-in MyStyle", whereas before save/load it was named "MyStyle"

Attached you find a sample spreadsheet.
Comment 1 Robinson Tryon (qubit) 2014-08-16 02:17:00 UTC
CONFIRMED on LO 4.3.1.1 + Ubuntu 12.04

(In reply to comment #0)
> 1) Create a new Spreadsheet
> 2) Create a new style (e.g. via "New Style from Selection), name it "MyStyle"
> 3) Save the document as xlxx

Saved as XSLX.

> 4) Close the Document
> 5) Open the document again
> => Now the Style appears in the list of styles as "Excel Built-in MyStyle",
> whereas before save/load it was named "MyStyle"

Confirmed.

Even if the format is XLSX, I don't think we'd need to rename the style to match the name 'Excel': The OOXML format should be vendor neutral (I think...)

Thanks for reporting this bug!
Comment 2 Urmas 2014-08-18 16:54:14 UTC
In master:
The first custom style is saved as 'customized Explanatory Text';
All other custom styles are silently lost (but present in styles.xml)
Comment 3 QA Administrators 2015-09-04 02:47:45 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-11-18 10:46:36 UTC
Still bugging: Excel Built-in Explanatory Text is what I get for the name.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: b216cc1b8096eb60c27f67e8c27b7cd756c75e38
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-12_00:06:20
Locale: fi-FI (fi_FI)
Comment 5 Bartosz 2016-07-01 06:30:29 UTC
Could you please check if this bug is reproducible with MS Excel?
1) Create a new Spreadsheet in MS Excel
2) Create a new style
3) Save the document as xlxx
4) Close the Document
5) Open the document with Calc
6) Save the document as xlxx with Calc
Comment 6 Buovjaga 2016-07-10 19:02:09 UTC
(In reply to Bartosz Kosiorek from comment #5)
> Could you please check if this bug is reproducible with MS Excel?
> 1) Create a new Spreadsheet in MS Excel
> 2) Create a new style
> 3) Save the document as xlxx
> 4) Close the Document
> 5) Open the document with Calc
> 6) Save the document as xlxx with Calc

I created a cell style in Excel 2013, but apparently LibO does not support them (I was unable to find it in LibO). Can you give a more detailed explanation of step 2?
Comment 7 Bartosz 2016-07-11 10:56:03 UTC
My intention was to compare original .xlsx file (created with MS ExceL), with the same .xlsx file exported by LibreOffice.

If Libreoffice is not supporting cell style created by Excel 2013, then please create new bug with description, ans sample file.
Comment 8 QA Administrators 2018-07-24 02:37:15 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2019-03-23 16:46:05 UTC
The naming has changed and there is a new report for it, so closing this as dupe.

*** This bug has been marked as a duplicate of bug 123428 ***