Download it now!
Bug 82658 - FILEOPEN: A parallelogram in DOCX canvas become a triangle
Summary: FILEOPEN: A parallelogram in DOCX canvas become a triangle
Status: RESOLVED DUPLICATE of bug 83306
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: bibisected, filter:docx, regression
Depends on:
Blocks:
 
Reported: 2014-08-15 11:40 UTC by Alexandr
Modified: 2016-09-29 19:25 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparative screenshot of MS Word 2007 and LO Writer 4.4 (66.77 KB, image/png)
2014-08-15 11:40 UTC, Alexandr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr 2014-08-15 11:40:17 UTC
Created attachment 104673 [details]
Comparative screenshot of MS Word 2007 and LO Writer 4.4

Open bug 74397 attachment 93238 [details]. A parallelogram in top row is shown as a triangle (see attached screenshot). This issue appears in 4.4 branch. In LibreOffice 4.3.1.1 the shape is correct.
Comment 1 Julien Nabet 2014-08-15 13:28:33 UTC
Would it be possible you attach the docx so we can try to reproduce/debug this?
Comment 2 Alexandr 2014-08-15 14:21:21 UTC
Hello, Julien.
The test file is attachment 93238 [details]. I see no reason to duplicate it.
Comment 3 Julien Nabet 2014-08-15 14:52:12 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce the problem. Except if the bug has just been fixed, I don't have any idea what could be the cause.
Comment 4 Alexandr 2014-08-15 15:16:07 UTC
Now I have tried LibreOffice 4.4.0.0.alpha0+ Build ID: a7d21497094f0320916d4f6f99af1439ad2c3eaf TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-08-14_07:13:06
and can not reproduce the bug.

I will try another windows build tomorrow.
Comment 5 Alexandr 2014-08-16 07:07:43 UTC
I reproduce the problem with  
 4.4.0.0.alpha0+
Build ID: 24931841534d232b5ebf6af5bee1e54b7cfae738
TinderBox: Win-x86@39, Branch:master, Time: 2014-08-12_02:01:00

 4.4.0.0.alpha0+
Build ID: d5642fe00cfd23d1470fa2062a93b30a612bbadd
TinderBox: Win-x86@42, Branch:master, Time: 2014-08-13_23:06:06

 4.4.0.0.alpha0+
Build ID: 0771823d80abadf8e7f2ccc078f3f9e2c277f8a5
TinderBox: Win-x86@42, Branch:master, Time: 2014-08-15_23:19:56

on Windows 7 x86_64.

Deleting user profile does not help.
Comment 6 Julien Nabet 2014-08-22 10:04:53 UTC
Alexandr: thank you for your feedback.

Joren: would you have some time to try to give it a try? (Windows only bug?)
Comment 7 Owen Genat (retired) 2014-08-23 13:30:32 UTC
(In reply to comment #3)
> On pc Debian x86-64 with master sources updated today, I don't reproduce the
> problem.

I can't reproduce it either here using v4.4.0.0.alpha0+ Build ID: e379401618268ed7f7f5885a36b90e1f4f6cd4af TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-08-18_05:51:03. May be Windows-only as you suggest Julien.
Comment 8 tommy27 2014-09-26 19:47:22 UTC
yes. Windows only bug.

I can reproduce it with  4.4.0.0.alpha0+
Build ID: faf99f6f405e076d5c9ab95c876ae1ffb896f8d1
TinderBox: Win-x86@39, Branch:master, Time: 2014-09-26_09:41:28

works fine with 4.3.1.2.  
4.4.x branch regression. status NEW.
Comment 9 Robinson Tryon (qubit) 2015-12-14 05:50:02 UTC Comment hidden (obsolete)
Comment 10 Xisco Faulí 2016-09-13 09:47:28 UTC
I guess this can be bibisected with this repository:
http://dev-downloads.libreoffice.org/bibisect/win/bibisect_win_44.tar.xz. Adding
keyword 'bibisectRequest'
Comment 11 raal 2016-09-29 17:21:35 UTC
 git bisect log
# bad: [489ffd1df414698b6cea9ab03bf6f663b8b5af7e] source-hash-3f94c9e9ddfd807b449f3bb9b232cf2041fa12d2
# good: [8aa9fc9a0c92172593d6cd97662116a965db229d] source-hash-dea4a3b9d7182700abeb4dc756a24a9e8dea8474
git bisect start 'latest' 'oldest'
# bad: [897913acd244cb6a5d2f4c2da1d625d9b978edb6] source-hash-ac57362b23859591c088e36b7218f4a606dcf3bb
git bisect bad 897913acd244cb6a5d2f4c2da1d625d9b978edb6
# bad: [dc97f44745f96315fb6c5480705bb5d595d39c6c] source-hash-01c8962f281887db59e581906b89d027a994b52a
git bisect bad dc97f44745f96315fb6c5480705bb5d595d39c6c
# good: [a5a39af2ec486b10b26d6373f58a9b59142106c4] source-hash-a595879302e26a616131aa0cab5de31bb287b37d
git bisect good a5a39af2ec486b10b26d6373f58a9b59142106c4
# bad: [54a9a5df46b192bd5b9bd44702ef3bffd5730523] source-hash-e2f1fffc81896c0773a18e468635056710927d8f
git bisect bad 54a9a5df46b192bd5b9bd44702ef3bffd5730523
# bad: [54a9a5df46b192bd5b9bd44702ef3bffd5730523] source-hash-e2f1fffc81896c0773a18e468635056710927d8f
git bisect bad 54a9a5df46b192bd5b9bd44702ef3bffd5730523
# good: [f1cbe8b4bb7351ee7ca566e6c29229948fcac423] source-hash-9263b101c39172cbcf04189c515bca80cb15f3aa
git bisect good f1cbe8b4bb7351ee7ca566e6c29229948fcac423
# good: [649737e10cac6fffed69f0b6f02d517ca5ff2a05] source-hash-c38be106ff1c1ff5e1b279e4ea2c710b524d23f1
git bisect good 649737e10cac6fffed69f0b6f02d517ca5ff2a05
# bad: [b9e32c086d6e3c96eb05ad80b0005afeb43305c8] source-hash-81df594b4fbb147d3e4b3cb31ae27ff7f66d83b4
git bisect bad b9e32c086d6e3c96eb05ad80b0005afeb43305c8
# bad: [30fbacc51969fa4e3f572b25142b58103956ed06] source-hash-da36ded02c67bb7481cd4378ce5f7d779c1a3533
git bisect bad 30fbacc51969fa4e3f572b25142b58103956ed06
# good: [1d9fe19e246fed2d4e059300c6c19232f64659cb] source-hash-1f90cae1debed4b45bb51ced21a03aacd7973cff
git bisect good 1d9fe19e246fed2d4e059300c6c19232f64659cb
# good: [1d9fe19e246fed2d4e059300c6c19232f64659cb] source-hash-1f90cae1debed4b45bb51ced21a03aacd7973cff
git bisect good 1d9fe19e246fed2d4e059300c6c19232f64659cb
# good: [e33eab517819eed0b577bb43de03305a9d2c3aa5] source-hash-6f92b58987f754de31c9ca756e813deb7462d98e
git bisect good e33eab517819eed0b577bb43de03305a9d2c3aa5
# first bad commit: [30fbacc51969fa4e3f572b25142b58103956ed06] source-hash-da36ded02c67bb7481cd4378ce5f7d779c1a3533


One of these commits:
2014-07-04	fix autotext	Caolán McNamara	1	-4/+4
2014-07-04	Related fdo#77603: update Spanish autocorrection patterns.	Adolfo Jayme Barrientos	1	-5/+140
2014-07-04	Use standard library optimised routines for OUString/OString	Noel Grandin	1	-60/+178
2014-07-04	fix spelling in class name OSpecialHanldeXMLExportPropertyMapper	Noel Grandin	2	-11/+11
2014-07-04	Fix: EE_CHAR_COLOR to EE_CHAR_BKGCOLOR	matteocam	1	-1/+1
2014-07-04	Avoid possible memory leaks in case of exceptions	Takeshi Abe	6	-47/+33
2014-07-04	Drop unused #includes	Takeshi Abe	2	-4/+0
2014-07-03	fdo#76803: writerfilter: fix image wrap polygon import again	Michael Stahl	1	-2/+4

http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=6f92b58987f754de31c9ca756e813deb7462d98e..da36ded02c67bb7481cd4378ce5f7d779c1a3533

Michael, the same bibisect result as in bug https://bugs.documentfoundation.org/show_bug.cgi?id=83306. Can it be related? Thanks
Comment 12 Michael Stahl (allotropia) 2016-09-29 19:25:51 UTC
yes thats the same bug

*** This bug has been marked as a duplicate of bug 83306 ***