Bug Hunting Session
Bug 82713 - Installer fails to install with old 3.4 present, I should terminate old version first
Summary: Installer fails to install with old 3.4 present, I should terminate old versi...
Status: RESOLVED DUPLICATE of bug 36677
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-16 22:39 UTC by Jonas Thiem
Modified: 2014-10-03 09:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonas Thiem 2014-08-16 22:39:29 UTC
Problem description: 
Installer for 4.2.6 fails with LibreOffice 3.4 installed, tells me to terminate it although it is not running. (Windows 7 x86-64)

Steps to reproduce:
1. Have LibreOffice 3.4 installed
2. Run installer for 4.2.6
3. It fails

Current behavior:
The installer requests admin privilegues (UAC) but then stops to claim I would still be running 3.4 which is false. After going through the hassle of a superuser cmd.exe to run it with admin privilegues right from the start, it worked. Obviously, this is nothing that could be expected from a regular user, therefore it should really be fixed.

Expected behavior:
Installer works.
Comment 1 Jean-Baptiste Faure 2014-08-18 04:28:36 UTC
Are you sure that you haven't the quickstarter of 3.4 version running ?

Set status to NEEDINFO. Please set it back to UNCONFIRMED once you have provided requested informations. Thank you for your understanding.

Best regards. JBF
Comment 2 Jonas Thiem 2014-08-18 09:23:26 UTC
Yes. Also why would having admin rights from the initial execution vs. having it later during actual install make ANY difference in the detection of a running quickstart process? That doesn't sound like it makes any sense.
Comment 3 Andras Timar 2014-10-03 09:55:40 UTC
It seems to be a duplicate of bug 36677.

*** This bug has been marked as a duplicate of bug 36677 ***