Bug 82725 - FORMATTING: Format Paintbrush not working with pasted text
Summary: FORMATTING: Format Paintbrush not working with pasted text
Status: RESOLVED DUPLICATE of bug 71481
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisected, regression
Depends on:
Blocks: Clear-Formatting
  Show dependency treegraph
 
Reported: 2014-08-17 11:03 UTC by bowlins
Modified: 2017-07-30 21:44 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of paste not working (8.85 KB, application/vnd.oasis.opendocument.text)
2015-02-03 11:43 UTC, davidpbrown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bowlins 2014-08-17 11:03:19 UTC
Problem description: I've just copied text from Chrome into a LibreOffice document. I've also used Format Paintbrush to coy formatting of my text into the new copied text. However, it doesn't work at all, including font, size, colour.

Steps to reproduce:
1. Cut and paste using CTRL+C
2. Use Format Paintbrush to copy format of already existing text into the new copied text

              
Operating System: Ubuntu
Version: 4.3.0.4 release
Comment 1 Jean-Baptiste Faure 2014-08-18 04:04:53 UTC
Please, could you describe step by step (mouse click by mouse click) how do you proceed to use the paintbrush in this case?

Set status to NEEDINFO. Please set it back to UNCONFIRMED once you have provided requested informations. Thank you for your understanding.

Best regards. JBF
Comment 2 bowlins 2014-08-18 15:32:19 UTC
1. I write some text
2. CTRL+C text from website
3. CTRL+V in LibreOffice document
4. Text has the same formatting as on website
5. Click on Format Paintbrush
6. Mouse pointer becomes paint bucket
7. Select text I pasted to apply formatting
8. Nothing happens
Comment 3 Jean-Baptiste Faure 2014-08-18 19:49:20 UTC
It seems that you missed to select first the text from which you wanted to copy the style. Please have a look at
https://help.libreoffice.org/Common/Format_Paintbrush
and
https://help.libreoffice.org/Common/Copying_Attributes_With_the_Format_Paintbrush
and see if it solve your problem.

Set status to NEEDINFO. Please set it back to UNCONFIRMED once you have provided requested informations. Thank you for your understanding.

Best regards. JBF
Comment 4 bowlins 2014-08-19 08:35:15 UTC
According to the help guide it's not necessary to have text selected. But I have tried with and without selection and still no success.
Comment 5 Buovjaga 2014-11-12 13:03:46 UTC
Maybe this is a case of, for example, bold formatting belonging to the entire paragraph in the pasted text.

I copied "Documentation" from this page: https://help.ubuntu.com/

Bold formatting wasn't removed until I used Ctrl-paint on the target word.

Please try painting while holding Ctrl and report here.

Ubuntu 14.10 64-bit Version: 4.4.0.0.alpha2+
Build ID: 1c526c9ddda5d52f7a4db5655a4ec60b8c62835c
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-11-11_23:20:41
Comment 6 bowlins 2014-11-20 10:44:35 UTC
Thanks for the comment. I have now narrowed the bug. 

I've followed the suggestions using https://help.ubuntu.com/

CTRL+Paintbrush did change the formatting as expecting when text was pasted into a new paragraph.

Problem persists when I paste text from that website into a paragraph I'm currently writing. 

This is where problem persists:

1. I write "This is my new paragraph "
2. I copy the title  "Official Ubuntu Documentation" from https://help.ubuntu.com/ IMMEDIATELY AFTER THE SPACE IN MY NEW PARAGRAPH
3. Paintbrush doesn't work (both with CTRL and without CTRL pressed)
Comment 7 Buovjaga 2014-11-20 10:59:27 UTC
(In reply to bowlins from comment #6)
> 1. I write "This is my new paragraph "
> 2. I copy the title  "Official Ubuntu Documentation" from
> https://help.ubuntu.com/ IMMEDIATELY AFTER THE SPACE IN MY NEW PARAGRAPH
> 3. Paintbrush doesn't work (both with CTRL and without CTRL pressed)

Changed to UNCONFIRMED as REOPENED is reserved for fixed bugs.

If I paste immediately after the space, the formatting is not copied over in the first place.
Comment 8 bowlins 2014-11-20 11:01:51 UTC
Do you mean the text is not copied with colour, font-size, etc.? It is in my case. 

I use LibreOffice with Ubuntu, not sure if there may be something about how Ubuntu handles copy/paste
Comment 9 Buovjaga 2014-11-20 11:06:43 UTC
(In reply to bowlins from comment #8)
> Do you mean the text is not copied with colour, font-size, etc.? It is in my
> case. 
> 
> I use LibreOffice with Ubuntu, not sure if there may be something about how
> Ubuntu handles copy/paste

Yes, it only retains its style when it is pasted in its own paragraph.
I tested in Ubuntu.

Both
Ubuntu 14.10 64-bit Version: 4.4.0.0.alpha2+
Build ID: a55adb16ece70360c88342ca008d5a9d5b9d5b52
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-11-18_22:04:40

and

Version: 4.3.3.2
Build ID: 430m0(Build:2)
Comment 10 bowlins 2014-11-21 10:09:19 UTC
Sorry, I'm not familiar with how bugs are processed for Libre Office. Should I include a screenshot of what happens on my screen?
Comment 11 Buovjaga 2014-11-21 19:22:23 UTC
(In reply to bowlins from comment #10)
> Sorry, I'm not familiar with how bugs are processed for Libre Office. Should
> I include a screenshot of what happens on my screen?

Yes, you can add a screenshot as an attachment. Some people even add screencaptured video clips of strange behavior.
Comment 12 davidpbrown 2015-02-03 11:43:04 UTC
Created attachment 113090 [details]
Example of paste not working

Attached an example. If you try to copy the format from any part of the DEF to the ABC, it fails to make any change. That example created from a blank document and formatting the ABC to be different.

Note however, that pasting format from ABC to DEF, does work.

I wonder then whether vanilla text that is simple and only the document's default formatting, doesn't play host to that format detail and then that detail is not made available when copying format from that text, where other text that has been formatted manually, does allow paste of formatting.


This bug maybe not easy to characterise fully but it's a big problem when pasting from spreadsheet or elsewhere. The copy from spreadsheet [Input line], is not as expected. That should copy as text only but appears to copy the formatting too. Then compounded with this bug in Writer makes transfer of data from spreadsheet more difficult than it should be, though pasting as Cntl-Shift-V gets round that.
Comment 13 Rostislav 'R.Yu.' Okulov 2015-02-03 20:21:49 UTC
CONFIRMED.
Comment 14 Rostislav 'R.Yu.' Okulov 2015-02-03 21:05:48 UTC
(In reply to davidpbrown from comment #12)
> Created attachment 113090 [details]
> Example of paste not working
> 
> Attached an example. If you try to copy the format from any part of the DEF
> to the ABC, it fails to make any change. That example created from a blank
> document and formatting the ABC to be different.

I have to declare this as regression because using Comment 12 I saw that file works fine with 3.5 but not with 4.3

7742d3f486b624b5467b51abdccf658dbbafc505 is the first bad commit
commit 7742d3f486b624b5467b51abdccf658dbbafc505
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Mon Dec 10 00:39:03 2012 +0000

    source-hash-836822522a2e9f009c0870cbbcd48d45bbd3c622
    
    commit 836822522a2e9f009c0870cbbcd48d45bbd3c622
    Author:     Rafael Dominguez <venccsralph@gmail.com>
    AuthorDate: Sat Jul 14 15:53:42 2012 -0430
    Commit:     Rafael Dominguez <venccsralph@gmail.com>
    CommitDate: Sun Jul 15 08:15:19 2012 -0430
    
        Create overlay for online templates.
    
        Change-Id: Ie09c91e23527d3e1389fc13bd13a8234bda080f3

:100644 100644 4139633eaae48833b5c99a8a96585d0419a26950 1b321839f886ee139062bb17a393d2a1affcd31a M      ccache.log
:100644 100644 9545b4da47ee1c814cc0f31514d40f8ab30194f2 2fd76f1416c514a6eea9cf04265ec460c860bfb5 M      commitmsg
:100644 100644 e679fecbd0522e3550cd8dc8b8b194671479a3ea df767f7d664fd5e785b597da65b0ee263346b212 M      dev-install.log
:100644 100644 a091e2c0d6b47e9cb56363e109e824b248b03f18 2ed5b8ab92fb1e963bd71441b275ed24e9e87569 M      make.log
:040000 040000 2a400d18b834fe0b7c04a75aa24b82d18195a41d 238648981137ddd02dbc39393d122f00e9ad4e96 M      opt
root@sniper-Compaq-615:/data/bibisect-43all# git bisect log
git bisect start
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
git bisect bad 423a84c4f7068853974887d98442bc2a2d0cc91b
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect good 65fd30f5cb4cdd37995a33420ed8273c0a29bf00
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect bad 8f4aeaad2f65d656328a451154142bb82efa4327
# good: [369369915d3582924b3d01c9b01167268ed38f3b] source-hash-45295f3cdceb4c289553791071b5d7f4962d2ec4
git bisect good 369369915d3582924b3d01c9b01167268ed38f3b
# good: [6fce03a944bf50e90cd31e2d559fe8705ccc993e] source-hash-47e4a33a6405eb1b5186027f55bd9cb99b0c1fe7
git bisect good 6fce03a944bf50e90cd31e2d559fe8705ccc993e
# good: [da317333e5675622f55c9dda17396c659af65320] source-hash-15af925c254f27046427de70a59011e2ac3d6bdb
git bisect good da317333e5675622f55c9dda17396c659af65320
# bad: [18518588d8414f446ece5591944766f5082ebef5] source-hash-82c25249e624cb54ca6d3293d1c3d0d8ebc208e0
git bisect bad 18518588d8414f446ece5591944766f5082ebef5
# bad: [89740762f0af849e492932bd71e59149cdcd5a00] source-hash-06f20d73da21342046a480a6b22af69901351328
git bisect bad 89740762f0af849e492932bd71e59149cdcd5a00
# bad: [66d8f76eaad7a1835bf0a828fb396b58b8f9dbaa] source-hash-21dd191b9fd5a75f7633ea27f745a347adb42ae3
git bisect bad 66d8f76eaad7a1835bf0a828fb396b58b8f9dbaa
# bad: [0f0c47e3376b69f432cbbc1a16b7f0006d748ca4] source-hash-45c8db7ec89978029db2027585da986794971f7c
git bisect bad 0f0c47e3376b69f432cbbc1a16b7f0006d748ca4
# bad: [7742d3f486b624b5467b51abdccf658dbbafc505] source-hash-836822522a2e9f009c0870cbbcd48d45bbd3c622
git bisect bad 7742d3f486b624b5467b51abdccf658dbbafc505
# first bad commit: [7742d3f486b624b5467b51abdccf658dbbafc505] source-hash-836822522a2e9f009c0870cbbcd48d45bbd3c622

Whiteboard -> bibisected
Keywords -> regression
Comment 15 Robinson Tryon (qubit) 2015-12-13 11:16:12 UTC Comment hidden (obsolete)
Comment 16 Xisco Faulí 2016-10-07 10:04:53 UTC
Is it really a regression?
I've just tried comment 12 and I can reproduce it in libreoffice 3.3 and libreoffice 3.5. Am I missing something?
Comment 17 Aron Budea 2017-02-09 01:58:29 UTC
Xisco, I don't get the bug up till 3.6.0.4, and get it in 4.0.0.3.
If you select DEF, and use Paintbrush tool on ABC, the formatting doesn't get copied in newer releases.

Additionally, bug 104920 appears to be a duplicate.
Comment 18 Aron Budea 2017-02-09 02:00:17 UTC
*** Bug 104920 has been marked as a duplicate of this bug. ***
Comment 19 Aron Budea 2017-07-30 21:44:04 UTC
I'd say this is the same as bug 71481.

*** This bug has been marked as a duplicate of bug 71481 ***