Bug 82735 - Select whole word by mouse omits the following space
Summary: Select whole word by mouse omits the following space
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Selection
  Show dependency treegraph
 
Reported: 2014-08-17 16:09 UTC by strategic_1
Modified: 2020-08-24 13:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
MS Office Word, when word is double clicked (78.64 KB, image/jpeg)
2014-08-17 18:23 UTC, retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description strategic_1 2014-08-17 16:09:38 UTC
When using Libre Office's word processor, Write, I have found (for years) that when I highlight then, delete a word or words, it does the delete, but also leaves an extra blank space behind. This then, necessitates my having to delete the space the program left before I can continue typing. Annoying.
Comment 1 retired 2014-08-17 18:22:28 UTC
OSX 10.9.4, LO 4.3.1RC1 confirmed

NEW, OS > ALL.

LO actually does what we tell it to (remove the word) and since there is a space in front of the word and afterwards, after the word is gone, two spaces are left.

While this is somewhat logical, it's very unpractical.

Word does select the space behind the word, if you double click the word. LO behaves differently and indeed only selects the word, resulting in the behavior described in this bugs description.
Comment 2 retired 2014-08-17 18:23:42 UTC
Created attachment 104770 [details]
MS Office Word, when word is double clicked
Comment 3 V Stuart Foote 2020-08-14 22:37:30 UTC
This is correct, reason being we often will apply DF or character styling to the selection made--we do not want to include the bounding space (of any flavor, 2-click word selection is made ICU word bounds).

Once a word is selected, LO provides simple <Ctrl>+<Shift>+<R,L cursor> will extend selection at word bounds.

This dual mode is far more useful, than a selection including the space.

IMHO => WF
Comment 4 Heiko Tietze 2020-08-15 08:14:51 UTC
Agree with Stuart. While it makes sense for the deletion use case we do not want the extra space in case of formatting.