Bug 82752 - VIEWING: Leading digit not displayed in Calc cell (OS X only)
Summary: VIEWING: Leading digit not displayed in Calc cell (OS X only)
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected)
Hardware: x86 (IA32) macOS (All)
: medium normal
Assignee: Not Assigned
Keywords: bibisected, bisected
: 83617 90948 (view as bug list)
Depends on:
Reported: 2014-08-18 08:07 UTC by alphabugreporter
Modified: 2016-07-06 21:57 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:
Regression By:

screenshot (24.31 KB, image/png)
2014-08-18 08:07 UTC, alphabugreporter
Previous partly obscured rendering (20.83 KB, image/png)
2015-03-28 05:11 UTC, Matthew Francis

Note You need to log in before you can comment on or make changes to this bug.
Description alphabugreporter 2014-08-18 08:07:34 UTC
Created attachment 104803 [details]

A1: 305
A2: =A1/7
Display: 3.5714285714 not 43.5714285714
Formatting issue?
When changing format or expanding cell, the full answer can be seen.
Comment 1 sophie 2014-08-18 08:23:23 UTC
Hi, I can't reproduce with under Linux, what is the version of LibreOffice you are using? Thanks - Sophie
Comment 2 Algot Runeman 2014-08-18 20:56:29 UTC
Cannot reproduce the error using LibreOffice on Kubuntu Linux. Need Macintosh feedback?
Comment 3 alphabugreporter 2014-08-18 23:57:15 UTC
Build is:
Build ID: 185f2ce4dcc34af9bd97dec29e6d42c39557298f
Comment 4 Urmas 2014-08-19 13:00:41 UTC
Do you have a Retina display?
Comment 5 alphabugreporter 2014-08-19 23:54:03 UTC
No Retina Display:

  Model Name:	MacBook Pro
  Model Identifier:	MacBookPro9,2
  Processor Name:	Intel Core i5
  Processor Speed:	2.5 GHz
  Number of Processors:	1
  Total Number of Cores:	2
  L2 Cache (per Core):	256 KB
  L3 Cache:	3 MB
  Memory:	16 GB
  Boot ROM Version:	MBP91.00D3.B08
  SMC Version (system):	2.2f41
Comment 6 Jacques Guilleron 2014-09-08 16:40:35 UTC
*** Bug 83617 has been marked as a duplicate of this bug. ***
Comment 7 Dominique LE CAMPION 2014-09-08 16:44:50 UTC
Reproduced on libreoffice version: build 958349dc3b25111dbca392fbc281a05559ef6848 on a Mac too:

Hardware Overview:

  Model Name:	Mac mini
  Model Identifier:	Macmini6,2
  Processor Name:	Intel Core i7
  Processor Speed:	2,6 GHz
  Number of Processors:	1
  Total Number of Cores:	4
  L2 Cache (per Core):	256 KB
  L3 Cache:	6 MB
  Memory:	16 GB
  Boot ROM Version:	MM61.0106.B03
  SMC Version (system):	2.8f0
System Software Overview:

  System Version:	OS X 10.9.4 (13E28)
  Kernel Version:	Darwin 13.3.0

Formula used in A1: =3000000/1565
Worked around by changing the cell format: scientific shows the right value.
Comment 8 Jacques Guilleron 2014-09-08 16:58:13 UTC

Since confirmed by Dominique, I set status to NEW.


Comment 9 Cor Nouws 2014-09-08 19:38:00 UTC
would it be a good idea to attach a testdocument?
Comment 10 Jean-Baptiste Faure 2014-09-13 18:52:02 UTC
@Dominique: do you see this behavior with an empty new file with default cell formatting ? Which font is used in default formatting ?

Best regards. JBF
Comment 11 Dominique LE CAMPION 2014-09-14 10:52:45 UTC

(In reply to comment #10)
> @Dominique: do you see this behavior with an empty new file with default
> cell formatting ? Which font is used in default formatting ?
> Best regards. JBF

Yes. The default font is Liberation Sans 10. The width is 2.26cm. 2.71cm also shows a different wrong result for =3000000/1565.

I can also reproduce the issue with Geneva 10 with width 2.26 or 2.71cm.

I also tried with LibreOffice Version:
Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72 but can't reproduce the issue.

Best regards,

Comment 12 Buovjaga 2014-11-27 08:54:08 UTC
Setting back to new and adding keyword regression per comment 11.
Comment 13 Markus Mohrhard 2014-12-08 06:53:15 UTC
@Norbert: Somehow that looks like a problem with the text positioning on Mac. As far as I remember you looked at this some time ago.
Comment 14 Matthew Francis 2015-02-13 07:29:04 UTC
I can reproduce the issue on
At the end of the OSX bibisect repository, the leading "4" is partially off the left edge of the cell, but is visible (the same is true at the start of the repository, so there's no further regression to bisect)

Setting Whiteboard:notBibisectable
Comment 15 Matthew Francis 2015-03-28 05:09:20 UTC
The specific issue that the leading digit isn't shown started at the below commit.

commit 21fc47e115530780ad45ae64e8076dc5e9fedb5e
Author: Kohei Yoshida <kohei.yoshida@collabora.com>
Date:   Wed Apr 16 11:41:19 2014 -0400

    fdo#75665: Fix the right-aligned case.
    Change-Id: I905c4e331f37ed2ffbdf5c89dde9fb6c9ca546cf

This commit could well itself be reasonable, but has compounded with the existing issue on OSX that the leading digit is sometimes partly obscured (which is a problem inherited from OOo)
Comment 16 Matthew Francis 2015-03-28 05:11:20 UTC
Created attachment 114411 [details]
Previous partly obscured rendering
Comment 17 raal 2015-04-30 05:42:18 UTC
*** Bug 90948 has been marked as a duplicate of this bug. ***
Comment 18 Robinson Tryon (qubit) 2015-12-13 11:11:02 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
Comment 19 Julien Nabet 2016-06-26 10:15:24 UTC
On MacOs 10.11.5 with master sources updated yesterday, I don't reproduce this.
I don't reproduce either with last LO version 5.1.4 (with brand new LO directory profile).
Comment 20 Julien Nabet 2016-06-26 10:16:33 UTC
BTW, I don't think there's still 32 bits version for LO Mac.
Comment 21 steve 2016-07-06 21:57:09 UTC
Confirming Juliens findings.

Can not reproduce using Version:
Build ID: e6c004dd9f24c32f5e7468182a5e8d42293ec7b6
CPU Threads: 4; OS Version: Mac OS X 10.11.5; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-06-17_06:40:25
Locale: de-DE (de.UTF-8)

Setting to WFM

If I missed something or anybody is still seeing this problem using 5.1.4 or newer, please re-open this tracker.