Bug Hunting Session
Bug 82815 - FILESAVE: When rectangle boxes are copied, size is lost after a save
Summary: FILESAVE: When rectangle boxes are copied, size is lost after a save
Status: CLOSED DUPLICATE of bug 62175
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-19 14:03 UTC by Derek Keats
Modified: 2014-08-19 23:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Illustration of the bug, showing what is different between creating the copy, and saving/re-opening the file. (493.46 KB, image/png)
2014-08-19 14:03 UTC, Derek Keats
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Derek Keats 2014-08-19 14:03:45 UTC
Created attachment 104890 [details]
Illustration of the bug, showing what is different between creating the copy, and saving/re-opening the file.

When rectangle boxes with text are copied, size is lost after a save. This happens whether the slide is duplicated using INSERT | DUPLICATE SLIDE, or whether a new slide is created and then the text boxes are copied and pasted. 

Steps to reproduce:
1. Create a rectangle symbol
2. Add text to the symbol shape
3. Resize the shape to what you want
4. Copy the shape to a new slide
5. Save the presentation
6. Close the presentation
6. Open the presentation

Current behavior: All the copied shapes on the duplicated or new slide will have lost their shape settings. 

Expected behavior: All the copied shapes on the duplicated or new slide should keep their shape settings. 

Observation: This appears to be due to [] Word wrap text in shape changing to [] Resize shape to fit text after saving. See attached images.

              
Operating System: Ubuntu
Version: 4.3.0.4 release
Comment 1 Derek Keats 2014-08-19 18:41:01 UTC
The same bug manifests if you drag a slide from one presentation to another, save it, and then reopen it.
Comment 2 Regina Henschel 2014-08-19 23:11:55 UTC
The error happens, if the formatting of the shape is done using a style. For the copied shape the style is correctly highlighted in the Style&Formatting-window, so that you think the style is applied. But in the saved document the attribute "style:parent-style-name", which should reference the style, is totally missing and so this information is lost.

*** This bug has been marked as a duplicate of bug 62175 ***