Bug 82948 - FORMATTING: Adding new AutoFormat entries appears to follow C or Unicode Upper-first collation
Summary: FORMATTING: Adding new AutoFormat entries appears to follow C or Unicode Uppe...
Status: RESOLVED DUPLICATE of bug 94173
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-08-22 13:25 UTC by tmarx
Modified: 2015-12-15 10:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
AutoFormat dialog with added "BUW" preset in wrong position after step 2. (56.38 KB, image/png)
2014-08-22 13:25 UTC, tmarx
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tmarx 2014-08-22 13:25:24 UTC
Created attachment 105103 [details]
AutoFormat dialog with added "BUW" preset in wrong position after step 2.

Problem description: 

Depending on the choosen name for a new AutoFormat preset, the new preset doesn't get saved. This affects names starting with capital "A" or "B" or any number. In short, every name that is sorted to the top.

Steps to reproduce:
1. select at least 2 cells and choose "Format -> AutoFormat..." from the menu
2. choose "Add" and insert e.g. "BUW" as "Name" and click "OK"
3. click "OK" again to close the dialog
4. repeat step 1.

Current behavior:

"BUW" is shown at the top of the list after step 2, but after step 4 the entry is gone. Additionally some default setting disappear.

Expected behavior:

The new entry is sorted at the correct position and permanently saved.
Operating System: Mac OS X
Version: 4.3.0.4 release
Last worked in: 4.2.6.2 release
Comment 1 dx486107 2014-09-09 12:49:06 UTC
I can reproduce this bug on Windows 7 64 Bit, Libreoffice v4.3.1.2.
Comment 2 Owen Genat (retired) 2014-09-14 11:56:18 UTC
As a result of comment 1, confirmed. Also reproducible under GNU/Linux using v4.3.1.2. 

Note that this is likely a collation issue as capital letters are merely being sorted prior to lowercase letters. Testing with a new entry "BuW" sees it sorted after "Brown", while "BrW" is sorted before to "Brown". It is likely that C or Unicode Upper-first collation is being used. It would be good to get this clarified to see whether anything can (or should) be done about this.

Status set to NEW. Platform set to All/All. Summary amended for clarity.
Comment 3 Julien Nabet 2015-09-16 12:17:02 UTC
About the initial pb, new autoformat is not saved if new first in the list, a more recent tracker has been opened.
I submitted a patch to review on Gerrit.

For the sorting, it could be interesting to have a specific tracker for this (if there's not one already).

*** This bug has been marked as a duplicate of bug 94173 ***
Comment 4 Robinson Tryon (qubit) 2015-12-15 10:51:13 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]