Bug Hunting Session
Bug 83011 - Table cell protection - Inconsistency in removing protection
Summary: Table cell protection - Inconsistency in removing protection
Status: RESOLVED DUPLICATE of bug 93713
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-24 11:24 UTC by Mark Bourne
Modified: 2015-09-09 18:35 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Bourne 2014-08-24 11:24:01 UTC
Cells of a table in Writer can be protected through either the Table menu or the right-click context menu. However, there is no option on the Table menu to remove protection; as far as I can see, the only way to do that is through the context menu to do that.

Steps to reproduce:
- Create a table in Writer.
- Select one or more cells.
- Look on the Table menu; note that there is a "Protect Cells" option.
- Right click on the selected cells; note that there is a Cell > Protect option.
- Use either of the above two options to protect the cells.
- Look on the Table menu; note that the "Protect Cells" option is disabled, and there is no option to remove protection.
- Right click on the selected cells; there is a Cell > Unprotect option.

Actual behaviour:
- There is no option on the Table menu to remove cell protection.

Expected behaviour:
- There should be an option on the Table menu to remove cell protection, when protected cells are selected.

Platform is set to Windows x86 as that's what I use, but I suspect this will affect all platforms.
Comment 1 Mark Bourne 2014-08-24 11:27:12 UTC
(In reply to comment #0)
> Steps to reproduce:
> - Create a table in Writer.
> - Select one or more cells.
> - Look on the Table menu; note that there is a "Protect Cells" option.
> - Right click on the selected cells; note that there is a Cell > Protect
> option.
> - Use either of the above two options to protect the cells.

Additional step needed here - re-select the cells protection was just applied to, since the cursor is moved after applying protection.

> - Look on the Table menu; note that the "Protect Cells" option is disabled,
> and there is no option to remove protection.
> - Right click on the selected cells; there is a Cell > Unprotect option.
Comment 2 MM 2014-08-28 18:38:06 UTC
Confirmed under windows 7 x64 with 4.2.6.3
Confirmed under mint 17 x64 with 4.2.6.3 and 4.3.1.2
Version 4.2.6.2 (windows) still had a menuitem 'table -> cell -> protect/unprotect'
This has been removed and 'protect cells' has been directly put in the table menuitem. I think this was to bring the windows version inline with the linux versions. Unfortunally they seems to have the same problem, no unprotect menuitem, a bit longer.

Set to NEW, ALL
First version under windows that has this bug is 4.2.6.3, set to v4.2.6.2 (can't set it to 4.2.6.3), but could be set lower as linux versions seems to have it for quite a while.
Comment 3 QA Administrators 2015-09-04 02:49:28 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.0.5 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-09-03
Comment 4 Mark Bourne 2015-09-09 18:35:49 UTC
As discussed in this mailing list thread:
  http://listarchives.libreoffice.org/global/users/msg45824.html
The context menu has been removed in LibreOffice 5.0 which, with no "Unprotect Cells" option in the Table menu, makes it difficult to remove table cell protection.

A new bug 93713 was filed to add the "Unprotect Cells" option to the Table menu and it looks like that's been resolved for the next 5.x release.

I guess this one may as well be closed as a duplicate of bug 93713...

*** This bug has been marked as a duplicate of bug 93713 ***