Bug 83018 - TABLE: Table control arrows don't appear then pointer's location is over the image
Summary: TABLE: Table control arrows don't appear then pointer's location is over the ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables Mouse-Cursor
  Show dependency treegraph
 
Reported: 2014-08-24 20:03 UTC by Garri
Modified: 2019-02-02 13:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
LO_table_over_image.odt (17.22 KB, application/vnd.oasis.opendocument.text)
2014-09-29 10:39 UTC, Garri
Details
without_arrow.png (100.76 KB, image/png)
2014-09-30 16:25 UTC, Garri
Details
with_arrow.png (101.32 KB, image/png)
2014-09-30 16:28 UTC, Garri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Garri 2014-08-24 20:03:02 UTC
Selection of tables, rows and columns using mouse doesn't work as described in Wiki (https://help.libreoffice.org/Writer/Selecting_Tables,_Rows,_and_Columns) then there is an image behind the table.

If you navigate mouse to select a row, column or whole table, black arrow doesn't appear but pop-up description like "Select table column" does. If I try to click while the pop-up description exists - I don't get selection.

Thanks!
Comment 1 Garri 2014-08-27 17:50:34 UTC
I've just found that the essential table operations with the mouse like "Adjust table row/adjust table column" are not working too then the table is in front of image. User has to adjust cell weight/height using ruler and table properties menu.
Comment 2 Yousuf Philips (jay) (retired) 2014-09-29 06:41:05 UTC
Hi Garri,

Please send us a sample document, as this makes it easier for us to verify the bug.
Comment 3 Garri 2014-09-29 10:39:13 UTC
Created attachment 107056 [details]
LO_table_over_image.odt

Hi Jay,

Please try to use table control actions on the image area. Thank you!
Comment 4 Yousuf Philips (jay) (retired) 2014-09-30 00:10:42 UTC
Hi Garri,

It worked fine for me using the instructions found in the wiki, as the black arrow does appear for me on 4.3.3 and 4.4 master on Linux Mint 13. Can you let me know which linux distro you are using and what graphics card your system uses.
Comment 5 Garri 2014-09-30 16:23:58 UTC
I'm using Gentoo, but the same problems are observed on 10 Ubuntu systems with different video cards (Intel, ATI, Nvidia).

Please check my screenshots. Thank you!
Comment 6 Garri 2014-09-30 16:25:41 UTC
Created attachment 107138 [details]
without_arrow.png

There is no control arrow then the pointer located over the image.
Comment 7 Garri 2014-09-30 16:28:04 UTC
Created attachment 107139 [details]
with_arrow.png

Here presented right behavior of the pointer.
Comment 8 Yousuf Philips (jay) (retired) 2014-09-30 19:38:36 UTC
Well according to your screenshots, your mouse isnt in the correct position. To select the table, your mouse should be at the tables north-west corner and to select a column, your mouse should be above the north of the column. Unfortunately i couldnt send in screenshots as my screenshots would only capture the mouse as a mouse icon and not what it was at that point in time.
Comment 9 Garri 2014-09-30 20:16:05 UTC
:) I think I failed to explain the problem. I've changed summary description. Any table manipulation action using pointer is affected by the problem. On the screenshots I tried to use 'Adjust table row' with pointer. Thank you!
Comment 10 Yousuf Philips (jay) (retired) 2014-09-30 20:52:52 UTC
I get you now and confirmed. :)

Version: 4.3.3.0.0+
Build ID: 14907346d792f2f93a00083bbab5086cf56ddb24
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:libreoffice-4-3, Time: 2014-09-26_03:39:23
Comment 11 Artem Vakhitov 2015-04-23 15:20:56 UTC
This is an issue for me in LibreOffice Writer 4.4.1.2 on Windows Vista, 32-bit Intel.
Comment 12 QA Administrators 2016-09-20 09:31:52 UTC Comment hidden (obsolete)
Comment 13 Garri 2016-09-20 20:45:12 UTC
The problem still exists in 5.1.4.2
Comment 14 Xisco Faulí 2017-09-29 08:50:55 UTC Comment hidden (obsolete)
Comment 15 Garri 2017-10-25 17:18:25 UTC
The issue is still reproducible using LO Version: 5.4.2.2.0+ (Build ID: Gentoo official package).
Comment 16 QA Administrators 2018-10-26 02:58:18 UTC Comment hidden (obsolete)
Comment 17 Garri 2018-10-27 07:24:36 UTC
The issue has not fixed yet.

Version: 6.1.1.2
Build ID: Gentoo official package
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.utf8); Calc: group threaded