Bug Hunting Session
Bug 83026 - Sidebar should open on the left side in accordance with the GNOME HIG
Summary: Sidebar should open on the left side in accordance with the GNOME HIG
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-24 23:15 UTC by Daniel Hulse
Modified: 2014-08-26 14:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Hulse 2014-08-24 23:15:27 UTC
The new (in-development) GNOME HIG specifies:
"Organize visual elements from top-to-bottom and left-to-right. This is the direction that people from western locales tend to read an interface, so that the items at the top-left will be encountered first. This ordering gives interfaces a hierarchy: those components that are viewed first are perceived to have priority over those that come after them. For this reason, you should place dominant controls above and to the left of the controls and content that they affect."

Since the sidebar controls content in the viewing window, it should be placed on the right by default in Writer and Calc. In Draw and Impress it should be placed between the slide/page switcher and the viewing window in order to follow the HIG.

Here's a link to the part quoted:
https://wiki.gnome.org/Design/HIG/Layout
Comment 1 V Stuart Foote 2014-08-24 23:45:39 UTC
Regardless of the GNOME HIG recommendation, could also make the argument that with the Start Center menu as implemented aligned left, that moving the SideBar to the left alignment would simply make for a more consistent UI.

But can also say that since we have left alignment of all toolbars, that SideBar positioned under the toolbars would actually appear awkward--as the main elements of the toolbars would be removed from the document being edited.

Setting new enhancement but suggest it needs considerable UX review.
Comment 2 Jean-Baptiste Faure 2014-08-25 05:03:56 UTC
I am pretty sure that the user does not want Gnome HIG decides for him how to arrange his workspace and if the sidebar should be on the left or on the right. It is clear for me that the user must be free to dock the sidebar on the side he wants.

In my daily work, I prefer to have the sidebar on the right side in Writer because, with this layout, the right end of the text is near the screen center and has a better visibility. Indeed the content of the document is more important than the sidebar, so it is the text that must have the better part of the screen.
In Calc I dock the sidebar on the right side too, because it is closed most of the time and, when I open it, that does not move the table on the screen.

Best regards. JBF
Comment 3 Urmas 2014-08-25 09:54:05 UTC
G**nome team may create their own office, with the sidebar on the left, top, or bottom.
We, normal users, want it to be where it belongs in the normal software since 2003: on the right.
Comment 4 Tin Man 2014-08-25 10:38:55 UTC
I agree with the Gnome HIG, but I would argue that the Sidebar does NOT have priority over document content. On the contrary: given that the sidebar is primarily contextual (i.e. the current state of the document defines what the sidebar shows), it only makes sense to have the document area on the left and the sidebar on the right. Navigation panes, on the other hand, make sense on the left, as the selection made within them defines what is shown in the document area.
Comment 5 Yousuf Philips (jay) (retired) 2014-08-25 11:37:52 UTC
(In reply to comment #1)
> Regardless of the GNOME HIG recommendation, could also make the argument
> that with the Start Center menu as implemented aligned left, that moving the
> SideBar to the left alignment would simply make for a more consistent UI.

Well with the new start center, the priority is about a user clicking the file thumbnails, so the icon alignment had to be moved to somewhere when previously they were all in the center. I personally would have preferred the icons being on the bottom. :)

(In reply to comment #2)
> I am pretty sure that the user does not want Gnome HIG decides for him how
> to arrange his workspace and if the sidebar should be on the left or on the
> right. It is clear for me that the user must be free to dock the sidebar on
> the side he wants.

By default, Word 2013 opens the navigation panel is on the left, but you have the option to move it to be floating or to the right, so giving the user the choice is always the best way to go.

> In my daily work, I prefer to have the sidebar on the right side in Writer
> because, with this layout, the right end of the text is near the screen
> center and has a better visibility. Indeed the content of the document is
> more important than the sidebar, so it is the text that must have the better
> part of the screen.

It would be my preference to have the sidebar on the right side as well, as the scroll bar is on the right and i use the mouse with my right hand, which results in the mouse pointer always being more on the right side.

> In Calc I dock the sidebar on the right side too, because it is closed most
> of the time and, when I open it, that does not move the table on the screen.

Yep that is another point of why i keep in on the right. :)
Comment 6 Adolfo Jayme 2014-08-26 02:46:54 UTC
After taking Mirek’s, Jean-Baptiste’s and Jay’s points (plus my vote of staying on the right side: why to introduce a change in Writer/Calc but not in Impress/Draw?) let’s mark this WONTFIX for now. Also, if we want to follow GNOME choices let’s at least wait for their designers to finish their specifications, let’s not work on in-progress HIGs.
Comment 7 Daniel Hulse 2014-08-26 05:44:24 UTC
It appears to me that many of you haven't actually tried working with a sidebar on the left. How could you--you've all responded far too quickly to have any credibility about this.

"I am pretty sure that the user does not want Gnome HIG decides for him how to arrange his workspace and if the sidebar should be on the left or on the right. It is clear for me that the user must be free to dock the sidebar on the side he wants."
This is a default. This bug isn't making it impossible to move the sidebar--it's merely making it the default. And yes, users do want apps that follow guidelines. If a user is using GNOME or any other desktop environment with a HIG, they expect the layout and appearance of the apps they use to be designed in a way that uses the visual language of the ecosystem. Not doing so makes your app look ugly and seem unintuitive. 

And when the sidebar is placed on the left, the effect of opening and closing it is the same on the viewable area as opening and closing it on the right, making it not any more intrusive than opening it from the left. (although the shifting of the area to the right can be a bit jerk-y)

"(plus my vote of staying on the right side: why to introduce a change in Writer/Calc but not in Impress/Draw?)"

This change would be in all of them. Impress and Draw would either have the sidebar on the left next to the slide chooser or integrate the slide chooser as part of the sidebar. I'll admit the first option is awkward, but it gets the job done.

"I agree with the Gnome HIG, but I would argue that the Sidebar does NOT have priority over document content. On the contrary: given that the sidebar is primarily contextual (i.e. the current state of the document defines what the sidebar shows), it only makes sense to have the document area on the left and the sidebar on the right. Navigation panes, on the other hand, make sense on the left, as the selection made within them defines what is shown in the document area."

Mirek, I have to admit I did agree with you when I was first thinking about this change, but, when thinking about how this idea works in practice, I changed my mind. If you look at the layout of an app like Geary, it flows from selecting accounts to emails to the email you are reading. While the components at the left are arguably less "important" than the email at hand, they are on the left because they act on the content at the right and therefore should be viewed first. In fact, if you look at gnome apps, the more "essential" stuff like content goes at the right, while the chrome is on the left. So the heirarchy that needs to be conveyed in top-to-botton left-to-right is not really about priority, but what you use to act on what. And in LibreOffice, the sidebar is used to act on the document, and not the other way around. While elements of the sidebar do change depending on what you are editing and looking at, the mental model of working with the sidebar is still that the sidebar acts on the document, not that the document acts on it. 

This deserves more discuttion.
Comment 8 Jean-Baptiste Faure 2014-08-26 08:02:39 UTC
(In reply to comment #7)
> It appears to me that many of you haven't actually tried working with a
> sidebar on the left. How could you--you've all responded far too quickly to
> have any credibility about this.

You can't know. Obviously, I tried. Even, with older versions without the sidebar I worked with the Navigator and the Stylist docked on the _left_ side. And I searched why I felt not very comfortable, until I move them on the right side. The issue is that when I look to the screen, I look preferably on the left and on the center of the screen. So it is there that the most important part of the window must be. And the most important part of the window is not the sidebar but my document.

Best regards. JBF
Comment 9 Jean-Baptiste Faure 2014-08-26 08:56:03 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > It appears to me that many of you haven't actually tried working with a
> > sidebar on the left. How could you--you've all responded far too quickly to
> > have any credibility about this.
> 
> You can't know. Obviously, I tried. 

I forgot to add that when I work on code with an IDE, I dock panels like Project manager or syntax analyzer on the left because code lines are generally short, and doing so, the beginning of the code lines are almost in the middle of the screen. So with the same reason, in some cases the best docking position is on the left side and in other it is on the right side.

Best regards. JBF
Comment 10 Yousuf Philips (jay) (retired) 2014-08-26 14:07:34 UTC
(In reply to comment #7)
> It appears to me that many of you haven't actually tried working with a
> sidebar on the left. How could you--you've all responded far too quickly to
> have any credibility about this.
>
> And when the sidebar is placed on the left, the effect of opening and
> closing it is the same on the viewable area as opening and closing it on the
> right, making it not any more intrusive than opening it from the left.
> (although the shifting of the area to the right can be a bit jerk-y)

I personally do not to use the sidebar in writer as i havent find suitable advantage to it over the toolbars, but i do keep it active to constantly check it out. But i have used the sidebar in calc and like it on the left side, as it doesnt move my view from the left corner of the screen, the same way i normally view things in IDEs like UltraEdit.

> This change would be in all of them. Impress and Draw would either have the
> sidebar on the left next to the slide chooser or integrate the slide chooser
> as part of the sidebar. I'll admit the first option is awkward, but it gets
> the job done.

Having the slides centered in impress i feel is a great thing as it keeps the users eyes in the center.

> Mirek, I have to admit I did agree with you when I was first thinking about
> this change, but, when thinking about how this idea works in practice, I
> changed my mind. If you look at the layout of an app like Geary, it flows
> from selecting accounts to emails to the email you are reading. While the
> components at the left are arguably less "important" than the email at hand,
> they are on the left because they act on the content at the right and
> therefore should be viewed first. In fact, if you look at gnome apps, the
> more "essential" stuff like content goes at the right, while the chrome is
> on the left. So the heirarchy that needs to be conveyed in top-to-botton
> left-to-right is not really about priority, but what you use to act on what.
> And in LibreOffice, the sidebar is used to act on the document, and not the
> other way around. While elements of the sidebar do change depending on what
> you are editing and looking at, the mental model of working with the sidebar
> is still that the sidebar acts on the document, not that the document acts
> on it. 

From what i've seen, navigation is normally placed on the left side (email clients, find in ms word, pdf viewers), while other things are placed on the right (styles in ms word, tag lists in text editors).

http://www.inndir.com/img/pimg/UltraEdit-dqdn-296.jpg
http://i.stack.imgur.com/ybBGe.png