Bug Hunting Session
Bug 83049 - spellcheck fails
Summary: spellcheck fails
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.5.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Spell-Checking
  Show dependency treegraph
 
Reported: 2014-08-25 09:14 UTC by robin
Modified: 2016-10-10 12:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Spell check settings 1 (136.43 KB, image/png)
2015-09-02 10:32 UTC, Max Eaves
Details
Spell check settings 2 (129.33 KB, image/png)
2015-09-02 10:32 UTC, Max Eaves
Details

Note You need to log in before you can comment on or make changes to this bug.
Description robin 2014-08-25 09:14:28 UTC
kubuntu linux.  Spellcheck worked fine yesterday, did not work today.  I have not changed any settings since then.  Now words like "adfadf" do not have wiggly red lines under them.  I ticked the "abc" wiggly red line box.  No luck.  Spent hours googling, other people have exactly the same problem, not just me.  I reset the  language, mucked about for ages.  Tried "tools -> options -> language settings -> writing aids -> check spelling as you type" and rechecked the box.  No luck.  Unchecked the box and checked it again.  No luck.  Sometimes it works, today it didn't.  Maybe it will work tomorrow.   Probably not.
Comment 1 Yousuf Philips (jay) (retired) 2014-09-14 00:59:36 UTC
Hello robin,

The problem may be due to your user profile, so please follow instructions at the following link to clear your profile < http://ask.libreoffice.org/en/question/903/where-are-the-libreoffice-data-profile-files/ >. Please let us know if it still persists.
Comment 2 Jean-Baptiste Faure 2014-09-21 18:02:52 UTC
Please, could you attach a test file for which spellcheck does not work on your LibreOffice installation ?

Best regards. JBF
Comment 3 robin 2015-03-07 18:36:06 UTC
Hllo again, updated to LibreOffice 4.4.1.2, Still problems with the
spellchecker.  It is the exactly same problem as last time.

A little while ago, I got the spellchecker working and could see wiggly
lines under misspelled words. Typed a few sentences, everything was fine.

Then the wiggly lines just disappeared, even for words like "asdadfaf".

Tools -> customize -> language settings -> writing aids -> "check
spelling as you type".  This is checked.  Please don't tell me to check
this: it is checked.

Spellcheck seems to work for five minutes or so, and then stops working.  Munted words  such as "sssdsss" do not have a wiggly red line.

Interestingly I had two documents open simultaneously, and spellcheck worked on one but not the other. 

Sorry I'm getting frustrated but I have wasted a lot of time on this,
and I am absolutely no further forward in getting it working reliably.

 best wishes, please please please fix this, it is driving me nuts.
Comment 4 Max Eaves 2015-09-02 10:30:49 UTC
Hello there,

I wanted to reopen this bug - under Version 4.4.5.2 (GNU/Linux - Fedora 22_x86_64) version.

I am in the UK, and therefore use a en-GB spelling checker.  I can confirm the following things:

I confirm that I have ditched my profile - deleting the .options/libreoffice/4 profile and I can confirm that the settings are as shown in my screenshots.

Same issue here really - spelling doesn't work at all - pressing F7 will ask if you wish to scan the whole document, but doesn't find any errors and that process exits.

Happy to help diagnose this issue; it may have something to do with the en-GB dictionary - which always seems to have been temperamental (going back to OpenOffice days).

Let me know what you want me to do.

Thanks


Max
Comment 5 Max Eaves 2015-09-02 10:32:00 UTC
Created attachment 118335 [details]
Spell check settings 1

Spell check settings from Tools->Options
Comment 6 Max Eaves 2015-09-02 10:32:39 UTC
Created attachment 118336 [details]
Spell check settings 2

Spell check settings from Tools->Options.
Comment 7 Yousuf Philips (jay) (retired) 2015-09-02 21:00:51 UTC
(In reply to Max Eaves from comment #6)
> Created attachment 118336 [details]
> Spell check settings 2
> 
> Spell check settings from Tools->Options.

The 'Western' drop down menu shows that you dont have spellchecking for English (UK). Languages with spellchecking installed will have an abc icon next to the language name. So open it up and see which languages have that icon. This likely can be solved by installing the necessary en-gb dictionary package in your package manager.
Comment 8 Buovjaga 2015-10-09 18:38:38 UTC
Did comment 7 solve it for everyone?

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 9 Xisco Faulí 2016-09-11 19:49:30 UTC Comment hidden (obsolete)
Comment 10 Xisco Faulí 2016-10-10 11:13:11 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-20161010