Bug 83084 - On 4.4 master, starting the slide show for any presentation crashes
Summary: On 4.4 master, starting the slide show for any presentation crashes
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other Mac OS X (All)
: highest critical
Assignee: Markus Mohrhard
URL:
Whiteboard: target:4.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-26 07:02 UTC by Matthew Francis
Modified: 2014-08-27 05:16 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace (4.4 master) (75.38 KB, text/plain)
2014-08-26 07:02 UTC, Matthew Francis
Details
Debug output (4.69 KB, text/plain)
2014-08-26 07:03 UTC, Matthew Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Francis 2014-08-26 07:02:18 UTC
Observed on OSX 10.9.4 / 4.4 master (310a852e012ecfc10e813bea64438c1a862bb2c0):

Steps to reproduce
1. Create a blank presentation
2. Click on "Slide Show - Start from first Slide"

It will then die with the attached backtrace.
There is also some debug output about corrupt OpenGL vertex shaders - also attached.


Not yet tested on other platforms.
Comment 1 Matthew Francis 2014-08-26 07:02:55 UTC
Created attachment 105263 [details]
Backtrace (4.4 master)
Comment 2 Matthew Francis 2014-08-26 07:03:19 UTC
Created attachment 105264 [details]
Debug output
Comment 3 tommy27 2014-08-26 07:38:37 UTC
not reproducible under Win7x64 using  4.4.0.0.alpha0+
Build ID: f4246fab77113147b36706a1f3d93e8724ff826b
TinderBox: Win-x86@42, Branch:master, Time: 2014-08-23_03:27:09
Comment 4 Julien Nabet 2014-08-26 09:06:04 UTC
Put it at NEW since there's a bt.

Markus/Zolnai: looking at git history searching from OGL, I thought you might be interested in this one.
Comment 5 Markus Mohrhard 2014-08-26 09:08:21 UTC
It is fixed already in my OSX branch. I might need to backport some of these fixes to master to prevent some problems.

We are using the OpenGL canvas because the ones in the list before it are not implemented on OSX.
Comment 6 Markus Mohrhard 2014-08-26 09:09:15 UTC
This only affects OSX. On Linux we use the cairo backend and on Windows the DX9 backend.
Comment 7 Commit Notification 2014-08-26 11:52:52 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=676efb67198d48be778035d07cacb71efef38dff

avoid picking the incomplete OGL canvas, fdo#83084



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Markus Mohrhard 2014-08-26 11:54:26 UTC
Just picked the commit from my feature/mac-opengl-fixes branch. That should fix your issue.
Comment 9 Matthew Francis 2014-08-27 05:16:42 UTC
Thanks for the help. That did indeed do the trick, and allowed me to get on with reproducing the bug I was actually trying to reach :)