Bug Hunting Session
Bug 83197 - WebQuery: crash for certain web link when "Detect special numbers" checked
Summary: WebQuery: crash for certain web link when "Detect special numbers" checked
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.1.1 rc
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-08-28 14:18 UTC by Kevin Suo
Modified: 2015-12-15 22:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-08-28 14:18:09 UTC
Steps to reproduce:

1. Insert -> Link to external data;

2. Input the following link and then hit ENTER:
http://investing.money.msn.com/investments/stock-income-statement/?symbol=BIDU

3. On "Import Options" dialog, check "Detect special numbers".

4. In "Avaiable table/area" choose "HTML_Tables", OK.

5. After the table is imported, click any of the cells.
-->Crash.

LibreOffice 4.3.1.2, Windows 7 X86.
Comment 1 raal 2014-09-02 20:49:19 UTC
I can confirm that the bug is present in master.
Version: 4.4.0.0.alpha0+
Build ID: 9dc883623f85f2ceec22c3e5c1750ff7acd3cac5
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-09-01_23:38:4
Comment 2 Kevin Suo 2014-10-16 07:01:53 UTC
The above mentioned link is now not exist any more,
This bug can not be investigated anymore because I am not sure where to find another url to reproduce.

Close as WORKSFORME. Will reopen if I find another url.
Comment 3 Robinson Tryon (qubit) 2015-12-15 22:05:16 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]