Download it now!
Bug 83213 - Integrity of formula and results are broken after Sorting.
Summary: Integrity of formula and results are broken after Sorting.
Status: RESOLVED DUPLICATE of bug 79441
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.1.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-29 01:42 UTC by jun meguro
Modified: 2014-10-11 10:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
sample of bug (19.56 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-08-29 01:42 UTC, jun meguro
Details
Explain bug (217.18 KB, application/pdf)
2014-08-29 01:43 UTC, jun meguro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jun meguro 2014-08-29 01:42:13 UTC
Created attachment 105399 [details]
sample of bug

Open attached file "calcsort.ods".
Sort column A,B,C,D by column A.
Cell A, B, D are sorted. But cell C is not.
Ctrl - Z
Result of the formula is broken.



Look at "calc_sort_explain.pdf".
Comment 1 jun meguro 2014-08-29 01:43:15 UTC
Created attachment 105400 [details]
Explain bug
Comment 2 Naruhiko Ogasawara 2014-08-29 02:01:09 UTC
This issue occurs with LibO Calc 4.3.1, not with 4.3.0.  It seems as a regression bug with 4.3.1.

In my case:

- After sorting, column C (contains sum() formula function) changes nothing
- However, after undo (ctrl-Z), all column except C undo sorting, and column C sorted at this time
Comment 3 Naruhiko Ogasawara 2014-08-29 02:15:38 UTC
Now I tried nightly (Build ID: 1babe37e4871b47e37bef35378a5cf622948aeca) and it works fine for me.

- Sort by column A: every columns includes C sorted well
- Ctrl-Z undo every columns includes C as a starting order
Comment 4 ign_christian 2014-08-29 15:08:48 UTC
I can confirm Naruhiko, not reproduced in latest daily:

Version: 4.3.2.0.0+
Build ID: 266a9536b5abf4c36fed1785ae657da923bbbb8d
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:libreoffice-4-3, Time: 2014-08-29_03:57:12

Anyway it seems to be a duplicate of Bug 45146 or Bug 81309. Please change the status as duplicate if you think so.
Comment 5 Jean-Baptiste Faure 2014-10-11 10:00:41 UTC
In fact this bug is a duplicate of bug 79441 which is fixed in version 4.2.6.2 :
https://wiki.documentfoundation.org/Releases/4.2.6/RC2

Best regards. JBF

*** This bug has been marked as a duplicate of bug 79441 ***