Bug Hunting Session
Bug 83218 - Macros: Macro Edit causes Recovery loop
Summary: Macros: Macro Edit causes Recovery loop
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
: 83216 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-29 03:04 UTC by bordmail4
Modified: 2015-12-15 10:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
macro file that displays the problem (211.06 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-08-29 03:04 UTC, bordmail4
Details
your macro (5.88 KB, text/plain)
2014-08-31 15:41 UTC, Jacques Guilleron
Details
Additional information (613 bytes, text/plain)
2015-02-21 12:55 UTC, butjadingen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bordmail4 2014-08-29 03:04:04 UTC
Created attachment 105403 [details]
macro file that displays the problem

Problem description: 
Trying to edit the embedded macro causes each time the recovery screen but does not solve the problem. Macro runs fine but cannot be edited

Steps to reproduce:
1. next day
2. open attached macro file
3. try to edit it's macro

Current behavior:
If I open another file I've used to copy paste some data from, then the problem is solved. There should't be any data relation outside each file. 

Expected behavior:
not to have this bug

PS: I may have sent a similar report earlier . If so, please ignore either one.
              
Operating System: Windows 7
Version: 4.3.0.4 release
Last worked in: 4.1.0.4 release
Comment 1 Jacques Guilleron 2014-08-31 15:41:25 UTC
Created attachment 105492 [details]
your macro
Comment 2 Jacques Guilleron 2014-08-31 15:44:05 UTC
Hi bordmail4,

I can edit the macro without problem.
I join it as attachment.

regards,

Jacques
Comment 3 Jacques Guilleron 2014-08-31 16:22:36 UTC
*** Bug 83216 has been marked as a duplicate of this bug. ***
Comment 4 bordmail4 2014-09-01 04:41:47 UTC
Hi Jacques,
  
  Thank you for your effort. I'm still having intermitent problems but I've narrowed it down to one or possible two causes

- at the start of each day or whenever I've made a "breakthrough" I create a new copy of the file (another name, filename 31 august, filemane 1 september etc) so if I wreck the macro, I loose only one day's work. 
  In this case, when I rename fron Win explorer the file and try to open the new one, I get the recovery screen. After some time I get it to work again (don't know precisely how)

- sometimes I copy a macro or part of macro from another file (for example topday I copyed a full Sub in the same module1, closed the soure file, created the new copy of this macro I work on and voila! recovery! )

So, it may have to do with renaming the file (maybe then the name does not match anymore with some arguments)
It certainly maintains some link to the file I've copyed macro code from and won't let me edit until I open first that souse file and after the file I'm working on.

Regards,
Daniel Bordeianu,
Romania




(In reply to comment #2)
> Hi bordmail4,
> 
> I can edit the macro without problem.
> I join it as attachment.
> 
> regards,
> 
> Jacques
Comment 5 raal 2014-12-08 12:04:13 UTC
I can not reproduce with LO 4.3.4, win7
Comment 6 Buovjaga 2014-12-16 13:26:04 UTC
Can't repro.

Win 7 64-bit Version: 4.5.0.0.alpha0+
Build ID: 170616e9f2d30c1302bbb5a7a4b588bc05cd5cc9
TinderBox: Win-x86@39, Branch:master, Time: 2014-12-12_01:58:46
Comment 7 butjadingen 2015-02-21 12:55:48 UTC
Created attachment 113577 [details]
Additional information
Comment 8 Buovjaga 2015-02-21 17:24:44 UTC
Adding your infos as a quote.

(In reply to butjadingen from comment #7)
> I have the same problem as bordmail4 since rd. about 5 days
>
> Additional information:
> I deleted the folder C:\Users\xxxxxx\AppData\Roaming\LibreOffice\4\user
> I started LO and could edit the macros. I saved the macro and tried again to edit it. LO crashes again.
>
> Embedded macros behave different from global macros.
> I can edit global macros. This could be a workaround.
>
> When I run embedded macros and I force it to run in a basic error exception the edit window opens and I can 
> edit the macro. This could be another workaround.
>
> Operating System Windows 8.1 64 Bit
> Version 4.3.6.2 
> Java 8 update 31 

I did another test in LibO 4.4.

1) Created a new calc file
2) Created a new embedded macro, pasting the contents of attachment 105492 [details]
3) Saved, reopened file
4) Edited normally without crash

Tried both with Java 8 update 31 and Java 7 update 67.

Win 7 Pro 64-bit, LibO Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: fi_FI
Comment 9 Joel Madero 2015-11-08 17:33:58 UTC
@bordmail4 -

It would be great if you could jump into the QA chat and walk us through the steps live as three QA members have failed to reproduce the issue.

http://webchat.freenode.net/?channels=libreoffice-qa
Comment 10 bordmail4 2015-11-09 05:16:56 UTC
(In reply to Joel Madero from comment #9)
> @bordmail4 -
> 
> It would be great if you could jump into the QA chat and walk us through the
> steps live as three QA members have failed to reproduce the issue.
> 
> http://webchat.freenode.net/?channels=libreoffice-qa

Hello, Joel,
I can't believe you're still tryingto solve that bug.
It was a major problem for me at the time but I've used then an older version of your program that worked and updated only recently. Thinks work now in 5.0.0.5

Please, close this as solved.  It's not current anymore and there must be more important bugs to solve 


P.S. there is something new I wanted to ask, though, but unrelated to macros: at times there is a sort of delayed refresh for both cells and icons (I'm a Calc guy): in a long file but not overly so, I am wrighting in a cell, enter write in the next, enter and so on and it takes some 5 seconds sometimes to see what I wrote, or changed with F2.
Comment 11 Joel Madero 2015-11-09 05:47:50 UTC
bordmail was kind enough to jump into the QA channel and say that this bug is no longer an issue. Closing it :)

@bordmail - feel free to jump in any time to say hello. We've got lots of beginner tasks if you have some spare time to contribute back to the project.
Comment 12 Robinson Tryon (qubit) 2015-12-15 10:51:13 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]