Download it now!
Bug 83248 - PRINTING: "Single-line" text box always printed in black
Summary: PRINTING: "Single-line" text box always printed in black
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Jean-Sebastien Bevilacqua
URL:
Whiteboard: BSA target:6.5.0 target:6.4.0.2
Keywords:
Depends on:
Blocks: Print-Dialog Print
  Show dependency treegraph
 
Reported: 2014-08-29 13:01 UTC by Mohamed-Ali BEN MANSOUR
Modified: 2020-01-31 10:35 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Problem when printing "Single-line" text box (11.98 KB, application/vnd.oasis.opendocument.text)
2014-09-01 08:50 UTC, Mohamed-Ali BEN MANSOUR
Details
Printed result (42.03 KB, application/postscript)
2015-01-15 20:04 UTC, Arnaud Versini
Details
Drawing document with textfield (9.88 KB, application/vnd.oasis.opendocument.graphics)
2015-01-15 20:21 UTC, Arnaud Versini
Details
Printed drawing document (29.58 KB, application/postscript)
2015-01-15 20:22 UTC, Arnaud Versini
Details
Other components with trouble ODT version (9.24 KB, application/vnd.oasis.opendocument.text)
2020-01-31 09:28 UTC, Arnaud Versini
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mohamed-Ali BEN MANSOUR 2014-08-29 13:01:39 UTC
Problem description: 
When you choose a font color for a text box having "Text type" setted to "Single-line", we always have black color in output for the printed document.

Steps to reproduce:
1. Activate the design mode.
2. Add a text box.
3. Insert a some text.
4. Choose a background color (green for example).
5. Choose a font color for the inserted text (white for example)
6. Define the "Text type" property as "Single-line".
7. File -> Print

Current behavior:
On the preview window, the font color is black for the text consided as a "Single-line".

Important: This bug does not appear when the "Text type" is setted to "Multi-line".

Expected behavior:
The font color is previewed and printed as it was defined.
              
Operating System: All
Version: 4.4.0.0.alpha0+ Master
Comment 1 Joel Madero 2014-08-29 18:27:32 UTC Comment hidden (obsolete)
Comment 2 Joel Madero 2014-08-30 06:34:54 UTC
Can't confirm on 4.3.1.2 release - if it exists in 4.4 it's a recent regression.

at Mohamed - please attach a document so that we don't have to recreate from scratch every time. Marking as NEEDINFO - once you attach a document set the bug to UNCONFIRMED. Keep in mind the stretch on our teams time - the more information you provide (and test documents) the easier it is for everyone involved.


Thanks!
Comment 3 Mohamed-Ali BEN MANSOUR 2014-09-01 08:50:48 UTC
Created attachment 105540 [details]
Problem when printing "Single-line" text box
Comment 4 Mohamed-Ali BEN MANSOUR 2014-09-01 08:53:26 UTC
@Joel: Sorry for cc'ing the bug:
- Tested in 3.x and 4.x => The issue is there (does not seem to be a regression)
- Test document attached.
Comment 5 Mohamed-Ali BEN MANSOUR 2014-09-19 10:08:39 UTC Comment hidden (no-value)
Comment 6 Mohamed-Ali BEN MANSOUR 2014-09-19 14:27:00 UTC Comment hidden (no-value)
Comment 7 Arnaud Versini 2014-09-19 18:10:58 UTC
Confirmed on OpenSuse factory and LibreOffice and LibreOffice 4.3.1.2 .

Chaning version according to this test.
Comment 8 Jacques Guilleron 2014-09-19 18:21:35 UTC
Hi Mohamed-Ali,

I confirm with LO 4.4.0.0.alpha0+
Build ID: 5aeb852efcabdd51545d5d41c92f4bf3cef1d663
TinderBox: Win-x86@39, Branch:master, Time: 2014-09-08_07:01:57
and Windows 7 Home Premium.

Several versions down to LO 3.5.3.2 showed the same behaviour.

Those text box properties are available only if you copy and paste the whole text in a new document. 
But change from Single line to Multi lines make this color issue.

Regards,

Jacques
Comment 9 Arnaud Versini 2014-09-19 18:53:07 UTC Comment hidden (obsolete)
Comment 10 Soufiane 2015-01-15 15:17:02 UTC Comment hidden (no-value)
Comment 11 Arnaud Versini 2015-01-15 18:13:29 UTC Comment hidden (no-value)
Comment 12 kujiu 2015-01-15 18:36:50 UTC Comment hidden (no-value)
Comment 13 Véronique Fritière 2015-01-15 19:43:47 UTC Comment hidden (no-value)
Comment 14 Arnaud Versini 2015-01-15 20:04:39 UTC
Created attachment 112313 [details]
Printed result
Comment 15 Arnaud Versini 2015-01-15 20:19:57 UTC
This bug is not related to Writer, same behavior in Draw.
Comment 16 Arnaud Versini 2015-01-15 20:21:42 UTC
Created attachment 112314 [details]
Drawing document with textfield
Comment 17 Arnaud Versini 2015-01-15 20:22:05 UTC
Created attachment 112315 [details]
Printed drawing document
Comment 18 Arnaud Versini 2015-01-15 21:11:42 UTC
It seems there is an attribute in forms/source/inc/FormComponent.hxx named m_nOriginalTextLineColor and in write only (only constructor)
Comment 19 Arnaud Versini 2015-01-15 22:01:46 UTC
Same issue with Numeric Field
Comment 20 QA Administrators 2016-01-17 20:02:14 UTC Comment hidden (obsolete)
Comment 21 Charles 2016-02-19 16:27:39 UTC
Confirmed in LO 5-1
Comment 22 Jean-Sebastien Bevilacqua 2017-01-31 16:38:23 UTC Comment hidden (obsolete)
Comment 23 QA Administrators 2018-02-01 03:44:50 UTC Comment hidden (obsolete)
Comment 24 Elyse Cordeau 2018-03-05 15:06:06 UTC
Tested again with the fallowing Writer versions:

Version: 6.0.2.1 (x64)
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU threads: 2; OS: Windows 10.0; UI render: default; 
Locale: en-US (en_US); Calc: group

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

The bug is there in both. 

Note: the bug is only there with the function "print", not with "export as pdf". So you'll see the bug if you use windows native print to pdf.
Comment 25 Jean-Sebastien Bevilacqua 2018-12-05 14:19:58 UTC
Hello,

I can reproduce it on 6.3.0.0.alpha0+

Sincerely,
Jean-Sébastien
Comment 26 Jean-Sebastien Bevilacqua 2019-03-11 14:12:54 UTC
Here a patch that fixes this bug:

https://gerrit.libreoffice.org/#/c/69047/
Comment 27 Xisco Faulí 2019-06-26 09:54:48 UTC
Commit restored in gerrit
Comment 28 Xisco Faulí 2019-09-26 10:19:53 UTC
(In reply to Xisco Faulí from comment #27)
> Commit restored in gerrit

Done again
Comment 29 Commit Notification 2019-12-20 09:57:06 UTC
Arnaud Versini committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/10d345faa087fa49692f38bb2ece22560f423ba7

tdf#83248: Use the right text color when printing fields

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 30 Commit Notification 2019-12-27 19:57:22 UTC
Arnaud Versini committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/b0b7a38bd0ae6261ceeea20b31523070bf66b806

tdf#83248: Use the right text color when printing fields

It will be available in 6.4.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 31 Arnaud Versini 2020-01-04 15:25:35 UTC
Is it necessary to backport in 6.3? 

Thanks in advance
Comment 32 Arnaud Versini 2020-01-31 09:26:24 UTC
Same problem with other components, patched submitted in gerrit
Comment 33 Arnaud Versini 2020-01-31 09:28:50 UTC
Created attachment 157549 [details]
Other components with trouble ODT version
Comment 34 Commit Notification 2020-01-31 10:35:15 UTC
Arnaud Versini committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/56eb50de018ac806f92e2dd76c698d54edfe6122

tdf#83248 Print using the right color for other components too.

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.