Bug 83250 - PRINTING / FORMATTING: Brochure printing doesn't honor paper size.
Summary: PRINTING / FORMATTING: Brochure printing doesn't honor paper size.
Status: RESOLVED DUPLICATE of bug 81065
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-29 13:36 UTC by jeffweb
Modified: 2014-08-30 06:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jeffweb 2014-08-29 13:36:10 UTC
I frequently want to print booklets, and the booklet printing feature of OpenOffice was always one of my favorites from years ago; however, it has never worked correctly on my Mac, and I've been waiting for it to get fixed. Here is the problem and how you can reproduce it (sizes below are in inches):


Set up your printer with 8.5x11 (US Letter) paper.

Set up a document with a page format of 5.5x8.5 (US Statement).

Put enough text in the document to make sure there are at least a couple of pages in the document.

Open the print dialog and select brochure mode.


After selecting brochure mode, the paper size gets changed to "Legal" and this can be verified by either printing or selecting "Open PDF in Preview."

EXPECTED BEHAVIOR
Since 5.5x8.5 is exactly half the size of 8.5x11, selecting brochure mode should print two-up on 8.5x11. I assume that some internal calculation is attempting to account for margins and determines that 8.5x11 is too small to contain the original pages, but this should not be. The end user should be responsible for using sane margins with respect to the capabilities of the printer, and the application should simply print 2-up.
Comment 1 jeffweb 2014-08-29 13:48:01 UTC
I think this bug is similar to https://bugs.freedesktop.org/show_bug.cgi?id=81065 but that one is based on Linux, and I wasn't sure if they are the same, so I'm posting this one as well.
Comment 2 Joel Madero 2014-08-30 06:26:08 UTC
Indeed - it's a dupe looks like. Setting the other one to ALL for platform. Thanks!

*** This bug has been marked as a duplicate of bug 81065 ***