Download it now!
Bug 83302 - FILEOPEN: When opening a form a message appears about read-only mode.
Summary: FILEOPEN: When opening a form a message appears about read-only mode.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium major
Assignee: Lionel Elie Mamane
URL:
Whiteboard: target:4.4.0
Keywords: regression
Depends on: 44081
Blocks:
  Show dependency treegraph
 
Reported: 2014-08-31 16:42 UTC by Robert Großkopf
Modified: 2014-09-03 07:14 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2014-08-31 16:42:31 UTC
Open a database.
Open a form in this database.
At the top of the form appears a message: "This document is opened in read-only Mode" together with a button "Edit document" (which doesn't work).

Could be it is planned as an "enhancement" for a form opened directly in Writer. For Base it shouldn't appear.
Also for Writer it must be able to set the document so it doesn't appear. The main function of a form is to input data, often for persons who won't edit any form. The message is very irritating for such persons.

I set the severity to "Major", because the handling of databases with this bug gets very difficult for persons, who should only use - not edit - a database.
Comment 1 Robert Großkopf 2014-08-31 16:43:50 UTC
Have forgotten to add the version of LO:
Version: 4.4.0.0.alpha0+
Build ID: 880c18f23068a1faf34f36a67161e3b85fffdea7
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-08-30_23:30:44
Comment 2 Lionel Elie Mamane 2014-08-31 17:52:42 UTC
Samuel / Cédric, the enhancement bug 80538 is interacting badly with the scenario of Base forms (which are Writer subdocuments of the Base .odb file). We should disable this infobar when the document (form) is opened in "normal mode" (as opposed to "design mode").
Comment 3 Lionel Elie Mamane 2014-08-31 19:20:39 UTC
The same approach as bug 44081 should work... I'm trying it.
Comment 4 Lionel Elie Mamane 2014-08-31 19:55:58 UTC
OK, I've got a working patch in https://gerrit.libreoffice.org/11219

However, it needs the fix to bug 44081 first.

Cédric, I'd appreciate if you could take a look at the fix of bug 44081 (namely https://gerrit.libreoffice.org/11152 ) and let me know if it is OK Writer-side (since I'm touching sw code).
Comment 5 Commit Notification 2014-09-01 07:51:07 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=542ae4e06f9f70e328a3e85f1272ead558b36766

fdo#83302 don't display read-only infobar for Base form in normal mode



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2014-09-01 08:46:14 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4e4ae20ab26937200d53caa15175e7847a790268

Revert "fdo#83302 don't display read-only infobar for Base form in normal mode"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-09-02 16:18:05 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7fb4fdcddca89a4191b83896a400e8835314da87

fdo#83302 don't display read-only infobar for Base form in normal mode



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.