Download it now!
Bug 83310 - FILEOPEN: Images missing in cognos 10.1 generated .xlsx charts
Summary: FILEOPEN: Images missing in cognos 10.1 generated .xlsx charts
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2014-08-31 19:32 UTC by Luke
Modified: 2020-06-15 05:08 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
cognos 10.1 generated .xlsx charts (12.65 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-08-31 19:32 UTC, Luke
Details
Screenshot of the original file in LO61 LO_Master (186.71 KB, image/png)
2019-05-13 12:10 UTC, Balázs Varga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2014-08-31 19:32:10 UTC
Created attachment 105503 [details]
cognos 10.1 generated .xlsx charts

Steps to reproduce:
1. open the attached charts.xlsx in LO 4.2+
2. observe the blank placeholders where the images should be

Current behavior:
no showing images

Expected behavior:
should show images
Comment 1 Julien Nabet 2014-08-31 20:17:20 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

I noticed this kind of logs on console:
warn:legacy.osl:15347:1:oox/source/docprop/docprophandler.cxx:312: For now unexpected tags are ignored!

Looking at comments on Apache, I see this
"...
- Microsoft Excel 2007 and Microsoft Excel 2010 --> fine, charts/images are shown
- Microsoft Excel 2013 --> the same as Rob has reported.
- I opened the document in Microsoft Excel 2007 and saved it without any change. This saved document opens fine in AOO and Microsoft Excel 2013
"
(from https://issues.apache.org/ooo/show_bug.cgi?id=123233#c5)

Miklos: how to know what tag(s) prevent from reading the charts?(Indeed, I don't know how to retrieve the tag from sal_Int32 nElement)
Comment 2 QA Administrators 2015-09-04 02:48:32 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-11-19 12:02:42 UTC
Still confirmed.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 66d2b72667792cb18b25805387824d636e2a455c
TinderBox: Win-x86@39, Branch:master, Time: 2015-11-18_02:35:53
Locale: fi-FI (fi_FI)
Comment 4 QA Administrators 2017-01-03 19:36:39 UTC Comment hidden (obsolete)
Comment 5 Luke 2017-01-04 02:37:41 UTC
Charts still missing in Version: 5.4.0.0.alpha0+ (x64)
Build ID: bf80bbb7b75febc2769d6b64e6981224982f8fe2
Comment 6 QA Administrators 2018-06-15 02:45:42 UTC Comment hidden (obsolete)
Comment 7 Balázs Varga 2019-05-13 12:08:14 UTC
Probably, this patch could help here too.

Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/b2fc2ad7beceaff660de684435a5c37d69cf8ae9%5E%21

tdf#100084 XLSX import: fix missing charts

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Balázs Varga 2019-05-13 12:10:17 UTC
Created attachment 151358 [details]
Screenshot of the original file in LO61 LO_Master
Comment 9 Luke 2019-05-13 16:09:31 UTC
Balázs,
Thanks for fixing this. One point from the original bug report:

https://issues.apache.org/ooo/show_bug.cgi?id=123233

-- Microsoft Excel 2007 and 2010 --> fine, charts/images are shown
-- Microsoft Excel 2013 and 2016--> the same as Rob has reported.
-- I opened the document in Microsoft Excel 2007 and saved it without any change. This saved document opens fine in AOO and Microsoft Excel 2013

So it appears the while 2007/2010 implementations allow for case mismatches, the spec actually does not allow it. 

Should there be a SAL_WARN when we hit this edge case?
Comment 10 Balázs Varga 2019-05-14 09:40:26 UTC
(In reply to Luke from comment #9)
> Should there be a SAL_WARN when we hit this edge case?

Luke, thanks for the feedback. This is only a workaround for the reported problems, because we only handled some specific case of case-insensitive match, but that's not generic by no means.

We've added a TODO to the related code part for our future developments: https://gerrit.libreoffice.org/plugins/gitiles/core/+/642389768e634b739a1d8354259b16bfcc695d17%5E%21

Also it is a one-time import fix for defective IBM Cognos files. I mean this patch also fixed the export part, so you can open the example file with MS-Office 2007/2010/2013/2016 without any XML error message after the LibreOffice export. So I do not think a SAL_WARN would be necessary when we hit this edge case.

Note: During the fix we based on https://wiki.openoffice.org/wiki/Office_Open_XML/Legacy_Implementation#Packaging_Conventions.