Bug Hunting Session
Bug 83391 - EDITING: formula reference changed after partial rows reordering
Summary: EDITING: formula reference changed after partial rows reordering
Status: RESOLVED DUPLICATE of bug 81633
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-09-02 10:26 UTC by Oliviero Talamo
Modified: 2015-12-15 10:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
a spreadshheet to reproduce the bug (60.25 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-09-02 10:26 UTC, Oliviero Talamo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliviero Talamo 2014-09-02 10:26:33 UTC
Created attachment 105590 [details]
a spreadshheet to reproduce the bug

Problem description: 
In some columns of a spreadsheet, A to K, I load some values.
In subsequent columns, L to Q, there are formulas that make some simple computation on the cells of the columns A to K.
The cells in columns A to K are not protected. The cells in columns L to Q are protected.
Now, I select a rectangular block of value cells (some rows, columns A to K), and make a row reordering (based on some value in a column from A to K): the formulas in the columns L to Q change reference. They "follow" the "value" cells, instead of being unchanged. To have no errors I must unprotect the spreadsheet and select all the columns for the row reordering.

Steps to reproduce:
1. Load and open the test file I have loaded
2. Select from column A to column K, from row 5 to row 14
3. Select Data, Order, choose column J as order key, and order

Current behavior:
The formulas in the columns from L to Q change the reference to the corresponding cells. For instance formula in cell L5 becomes H14-I14, and so on.

Expected behavior:
Cells in columns L to Q should be unchanged. For instance, after reordering, cell L5 should be H5-I5, as before partial ordering.

The only way to reorder without errors is select all the columns for row reorder.
Operating System: Windows XP
Version: 4.3.1.2 release
Last worked in: 4.1.6.2 release
Comment 1 Jacques Guilleron 2014-09-02 11:49:37 UTC
Hi Oliviero,

Thank you for the report. However, this was previously noticed in Bug 81633 - Sorting shouldn't always automatically adjust references.
Set status to Duplicate.

regards,

Jacques

*** This bug has been marked as a duplicate of bug 81633 ***
Comment 2 Oliviero Talamo 2014-09-02 22:07:23 UTC
Hi Jacques,

thanks for your comment. 
I added this bug because my test seemed to me lightly different from 81633 (wrong result if order of part of columns, right if all columns), but, really, as you noted, in fact it is the same problem. So, thanks for your note and for setting it as duplicate.

Regards

Oliviero
Comment 3 Robinson Tryon (qubit) 2015-12-15 10:57:55 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]