Bug 83451 - MAILMERGE: Mail Merge Field Lost When Word 2003 Document Is Resaved as a 2003 Document
Summary: MAILMERGE: Mail Merge Field Lost When Word 2003 Document Is Resaved as a 2003...
Status: RESOLVED DUPLICATE of bug 67207
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-03 19:20 UTC by richardfromrancho
Modified: 2015-04-09 11:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A simple Word 2003 Document with a working Merge field. When resaved you will see the merge field will lose it's highlight and cease being able to merge. (20.50 KB, application/msword)
2014-09-03 19:20 UTC, richardfromrancho
Details

Note You need to log in before you can comment on or make changes to this bug.
Description richardfromrancho 2014-09-03 19:20:19 UTC
Created attachment 105701 [details]
A simple Word 2003 Document with a working Merge field.  When resaved you will see the merge field will lose it's highlight and cease being able to merge.

Problem description: 

Steps to reproduce:
1. ....Open and existing Word 2003 Document with a Merge Field
2. ....Make Resave the document and chose Word 2003
3. ....Check the documents Merge Field and find it no longer functions

Current behavior:
The Merge Field turns to text and loses it's database cabilities.  When the merge function runs the field is ignored and nothing the expected items do not merge.

Expected behavior:
The field should show as highlighted as when first opened.  When it's saved with or without any changes made the highlight of the field is lost and the merge ceases working.

              
Operating System: Windows 8
Version: 4.2.6.2 release
Comment 1 richardfromrancho 2014-09-03 19:54:40 UTC
The problem also occurs in version  4.3.1.2
Comment 2 Cor Nouws 2014-09-03 20:10:46 UTC
Hi Richard,

Thanks for reporting. It's an already filed bug (and as far as I am aware as old as OpenOffice.org).
regards,
Cor

*** This bug has been marked as a duplicate of bug 67207 ***