Download it now!
Bug 83464 - FILEOPEN: RTF - Frame text not retaining font name
Summary: FILEOPEN: RTF - Frame text not retaining font name
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:4.4.0
Keywords: bisected, filter:rtf, regression
: 84534 (view as bug list)
Depends on:
Blocks: RTF
  Show dependency treegraph
 
Reported: 2014-09-03 23:41 UTC by Yousuf Philips (jay) (retired)
Modified: 2015-12-17 12:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-09-03 23:41:19 UTC
Steps:
1) Open attachment 104064 [details]
2) One page 2, the text in the 2 frames used to be Verdana and they are are now times new roman.

Tested in 4.2.6, 4.3.2 and master on Linux. This is a regression that happened within the last month, during the time of bug 81944.
Comment 1 Miklos Vajna 2014-10-18 15:08:29 UTC
Yes, I can confirm this.

After bibisecting this, the problematic range, restricted to the writerfilter module is:

git log 418c5f7a4911bb2f1a06858556131b1bc4ad54f6..dacab84536f61f79a5422e1d8d394019ec62f3ec -- writerfilter

The range has a couple of commits from Michael, CC'ing him as well.
Comment 2 Yousuf Philips (jay) (retired) 2014-10-18 15:35:45 UTC
Hi Miklos,

It happened during bug 81944 < http://cgit.freedesktop.org/libreoffice/core/commit/?id=f8e8e476aa0a5576234dbb4daac9dc299e044e61 > and you told me to file a new bug for this. :)
Comment 3 Miklos Vajna 2014-10-18 17:06:43 UTC
Yes, though git bisect says that this is a regression from 36246aa9fb57c9fe4e546c91a8274d8828b1424e. I think I know what's going on here, on resetting character properties our RTL and run type states are not reset, but they should be.
Comment 5 Miklos Vajna 2014-10-19 11:00:03 UTC
libreoffice-4-3 backport: https://gerrit.libreoffice.org/12034
Comment 6 Miklos Vajna 2014-11-14 21:10:29 UTC
*** Bug 84534 has been marked as a duplicate of this bug. ***
Comment 7 Robinson Tryon (qubit) 2015-12-17 12:51:40 UTC
Migrating Whiteboard tags to Keywords: (filter:rtf)
Remove redundant rtf_filter.
[NinjaEdit]