Bug Hunting Session
Bug 83493 - Hangs for very long time on paste from web page
Summary: Hangs for very long time on paste from web page
Status: RESOLVED DUPLICATE of bug 45307
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2014-09-04 12:51 UTC by dx486107
Modified: 2015-01-21 07:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Debug output from 4.4 master showing HTTP requests resulting from the paste (36.05 KB, text/plain)
2014-09-05 06:03 UTC, Matthew Francis
Details
console_bt with master sources (17.64 KB, text/plain)
2014-09-06 05:56 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dx486107 2014-09-04 12:51:12 UTC
To reproduce the bug:

1. Open a new Libreoffice Writer document.

2. Goto http://divit.library.itu.edu.tr/search*tur?/Xfidic&SORT=DZ/Xfidic&SORT=DZ&extended=0&SUBKEY=fidic/1%2C13%2C13%2CB/frameset&FF=Xfidic&SORT=DZ&6%2C6%2C

3. Make a selection starting from "Title" until "RAFTA" and copy it.

4. Paste it into the document.

I have noticed this bug on several occasions while pasting text from various sources on my OS X (Mavericks) 64 bit and Windows 7 64 bit.

I have just lost my whole document because of this bug. 

I use Libreoffice Version: 4.3.1.2.
Comment 1 Matthew Francis 2014-09-05 06:02:12 UTC
Confirmed on OSX 10.9.4 / LO 4.3.1.2, 4.4 master

It doesn't crash for me, but does hang for a very long time (several minutes, without using CPU) before returning.

Based on the debugging output from master, I can see that LO is actually attempting to fetch some data over HTTP (!) when the paste is made, and that this is blocking. Writer returns to life after the requests finish.

-> Set to NEW
-> Platform: All
-> Version: 4.3.1.2 release (earlier versions not tested)


Debugging output attached following.
Comment 2 Matthew Francis 2014-09-05 06:03:44 UTC
Created attachment 105778 [details]
Debug output from 4.4 master showing HTTP requests resulting from the paste
Comment 3 Matthew Francis 2014-09-05 06:24:50 UTC
Incidentally, more UI-blocking HTTP requests occur when I try to close the document...
Comment 4 MM 2014-09-05 17:01:15 UTC
Confirmed (the hanging, not the crashing) for LibreOffice 3.3.4 and Go-OO 3.2.0 under windows 7, so setting it to 'Inherited from OOo'.
Comment 5 Julien Nabet 2014-09-06 05:56:39 UTC
Created attachment 105826 [details]
console_bt with master sources

On pc Debian x86-64 with master sources updated yesterday, I could reproduce this.
There's an hanging in WebDavNeon part.
Comment 6 Julien Nabet 2014-09-06 05:58:14 UTC
Matúš: one for you? (since WebDavNeon related)
Comment 7 Julien Nabet 2014-09-06 06:18:18 UTC
Hmm, to be precise I did not reproduce a crash but it hangs.
Comment 8 dx486107 2014-09-07 15:15:01 UTC
(In reply to comment #7)
> Hmm, to be precise I did not reproduce a crash but it hangs.

I am sorry for the wrong definition. It does not immediately crash but hangs for very long time. I did not wait too long. 

It is stated in the comments that Writer returns back to life after long time. Therefore I edited the title. 

Thank you for correction and confirming the bug.
Comment 9 Matthew Francis 2015-01-21 07:56:03 UTC

*** This bug has been marked as a duplicate of bug 45307 ***