Bug Hunting Session
Bug 83496 - FILEOPEN: Image wrongly occluded when opening .docx
Summary: FILEOPEN: Image wrongly occluded when opening .docx
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:docx
Depends on:
Blocks: DOCX-Images
  Show dependency treegraph
 
Reported: 2014-09-04 13:33 UTC by ravingdesi
Modified: 2017-09-19 14:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
bugdoc in OOXML format (39.74 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-09-13 19:04 UTC, Jean-Baptiste Faure
Details
how it looks in MS-Word 2010 (44.15 KB, image/png)
2014-09-13 19:06 UTC, Jean-Baptiste Faure
Details
how it looks in LibreOffice (38.82 KB, image/png)
2014-09-13 19:07 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ravingdesi 2014-09-04 13:33:52 UTC
When opening a .docx file, an image is occluded despite it should not be. (Note: this also happens if it's saved as .doc instead).

Steps to reproduce:
1. Download https://dl.dropboxusercontent.com/u/17406199/bugtmp/Bug14.docx
2. Open in libreoffice
3. Compare to results in MS office

Current behavior:
Currently, libreoffice shows a white box over the logo:
https://dl.dropboxusercontent.com/u/17406199/bugtmp/Bug14_2.png

Expected behavior:
Should look as in MS office (screenshot from office 2010):
https://dl.dropboxusercontent.com/u/17406199/bugtmp/Bug14_1.png
Operating System: Ubuntu
Version: 4.3.1.2 release
Comment 1 ravingdesi 2014-09-04 13:36:15 UTC
To add: It is not just displayed incorrectly, but is also wrong if printed or exported to pdf.
Comment 2 Jacques Guilleron 2014-09-05 16:46:10 UTC
Hi ravingdesi,

Ms office put image "behind the text" and LibreOffice "In background"... So, I don't know if there is a bug here. 
Anyway, selecting image and in Picture > Wrap > Options, uncheck In background give you the right location.

What do you think of?

Jacques
Comment 3 ravingdesi 2014-09-09 08:21:15 UTC
Dear Jacques,

thank you very much for your reply. I am sorry, but I am just a user and cannot fully understand your comment. To me, the problem is that the document cannot be used as expected because the image is partly occluded. In MS Office it can be seen and is printed correctly. In LO it can only be partly seen and is printed incorrectly (see comparison in screenshots).

Your workaround worked well, so thank you for that as well. But isn't it a bug if the document behaves differently? I don't quite understand why the "in background" attribute was checked in the first place. If there is a textbox in front of it (I believe that is what you are trying to say) and in MS office the image can be seen through while in LO is is occluded, then that sounds like the docx is not interpreted correctly to me.

But understandably, the final verdict is up to the people on this tracker as to decide what is a bug and what isn't.
Comment 4 Jacques Guilleron 2014-09-12 07:19:03 UTC
I reproduce with LO 4.3.1.2 & Windows 7 Home Premium. Set status to NEW.

regards,

Jacques
Comment 5 Jean-Baptiste Faure 2014-09-13 19:04:50 UTC
Created attachment 106227 [details]
bugdoc in OOXML format
Comment 6 Jean-Baptiste Faure 2014-09-13 19:06:36 UTC
Created attachment 106231 [details]
how it looks in MS-Word 2010
Comment 7 Jean-Baptiste Faure 2014-09-13 19:07:10 UTC
Created attachment 106232 [details]
how it looks in LibreOffice
Comment 8 Jean-Baptiste Faure 2014-09-13 19:08:24 UTC
Attached documents from description.

Best regards. JBF
Comment 9 Xisco Faulí 2015-08-19 10:48:24 UTC
Problem still present in

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: es-ES (es_ES)

on Windows 7 (64-bit)
Comment 10 QA Administrators 2016-09-20 10:26:09 UTC Comment hidden (obsolete)
Comment 11 ravingdesi 2016-10-03 10:27:54 UTC
Still present in LO 5.1.5.2 on Windows 10.
Comment 12 Xisco Faulí 2016-11-16 23:26:35 UTC
Still reproducible in

Version: 5.3.0.0.alpha1+
Build ID: 757a60d01dd152aadab2ba3c8224252481ce8a88
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 13 Xisco Faulí 2017-09-19 14:52:08 UTC
Fixed in

Version: 6.0.0.0.alpha0+
Build ID: dd5868409ae430f9c9ffea18ea7e287a65cfa2ab
CPU threads: 4; OS: Linux 4.10; UI render: GL; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Closing as RESOLVED WORKSFORME
Comment 14 Xisco Faulí 2017-09-19 14:54:12 UTC
[Improvement found by office-interoperability-tools]