Bug 83517 - Chart misplace and not display
Summary: Chart misplace and not display
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 81107
  Show dependency treegraph
 
Reported: 2014-09-05 06:28 UTC by xukai
Modified: 2015-04-09 11:16 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot (328.60 KB, image/png)
2014-09-05 06:28 UTC, xukai
Details
The document I want to open (2.36 MB, application/zip)
2014-09-11 03:05 UTC, xukai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xukai 2014-09-05 06:28:28 UTC
Created attachment 105780 [details]
screenshot
Comment 1 Jan Holesovsky 2014-09-10 12:45:44 UTC
Xukai: Which version have you tried - can you please give the commit ID from the About dialog?  Thank you!
Comment 2 Michael Meeks 2014-09-10 14:57:11 UTC
It may also be necessary to re-make the demo spreadsheet adjusting the position of the embedded object; since the new embedded 3D objects are positioned more accurately in line with other objects; hopefully that'll fix the issue.
Comment 3 xukai 2014-09-11 03:03:33 UTC
commit ID:5ef4bdc7b15686e55fa19f2e98a828763a0cfae6
> Xukai: Which version have you tried - can you please give the commit ID from
> the About dialog?  Thank you!
Comment 4 xukai 2014-09-11 03:05:00 UTC
Created attachment 106101 [details]
The document I want to open
Comment 5 Michael Meeks 2014-09-15 09:46:22 UTC
xukai: can you check:

a) that if you re-position the chart, save and re-load that it is in the same place that you saved it in ?
b) if so, close the bug.

this is an experimental feature, and the old positioning was broken - we now fixed it; which results in a one-off movement for older files, and of course we can't expect it to be in the same position when loaded in both old and new implementations - so we need to move to just the new one => c'est la vie [ I believe ]. The new positioning code is far better & more accurate.

Please re-open if a document edited/poisitioned, saved and re-loaded using a master build results in a different position.

Thanks.
Comment 6 xukai 2014-09-16 02:15:00 UTC
My master branch version is hang now,I am building new version, I will check it as soon as possbile.

> xukai: can you check:
> 
> a) that if you re-position the chart, save and re-load that it is in the
> same place that you saved it in ?
> b) if so, close the bug.
> 
> this is an experimental feature, and the old positioning was broken - we now
> fixed it; which results in a one-off movement for older files, and of course
> we can't expect it to be in the same position when loaded in both old and
> new implementations - so we need to move to just the new one => c'est la vie
> [ I believe ]. The new positioning code is far better & more accurate.
> 
> Please re-open if a document edited/poisitioned, saved and re-loaded using a
> master build results in a different position.
> 
> Thanks.