Download it now!
Bug 83525 - UI: Undocked sidebar doesn't resize properly
Summary: UI: Undocked sidebar doesn't resize properly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2014-09-05 10:23 UTC by Nick Dyer
Modified: 2016-10-24 15:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of issue (37.66 KB, image/png)
2014-09-05 10:23 UTC, Nick Dyer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Dyer 2014-09-05 10:23:10 UTC
Created attachment 105792 [details]
Screenshot of issue

Problem description: 

Steps to reproduce:
1. Undock sidebar
2. Resize sidebar window
3. Change sidebar type

Current behavior: Sidebar buttons appear in middle of window on top of other UI elements

Expected behavior: Buttons appear at right

This in on Ubuntu 14.04.
Operating System: Ubuntu
Version: 4.2.6.2 release
Comment 1 V Stuart Foote 2014-09-05 14:26:08 UTC
On Windows 7 sp1, 64-bit with current release
Version: 4.3.1.2
Build ID: 958349dc3b25111dbca392fbc281a05559ef6848

You don't mention which LO component, so we'll assume all.

Not clear what you are commenting on. When undocked the dialog holding the sidebar panel can be resized, but it is not stateful for its content. As you select different tabs to change the content panel in the deck, the dialog window does not resize. That is as designed.

Are you suggesting an enhancement that the dialog window for the undocked sidebar should resize to minimally fit the active content panel?
Comment 2 Nick Dyer 2014-09-05 14:32:28 UTC
I can reproduce this in Writer, Calc, Impress. I stopped trying then.

Look at the image I attached, it might not be reproducible on your platform.
Comment 3 V Stuart Foote 2014-09-05 14:50:28 UTC
(In reply to comment #2)
> I can reproduce this in Writer, Calc, Impress. I stopped trying then.
> 
> Look at the image I attached, it might not be reproducible on your platform.

That's ugly! I can't confirm on the 4.3.1 release for Windows.

Anyone?
Comment 4 Buovjaga 2014-11-13 13:06:40 UTC
Can't repro.

Ubuntu 14.10 64-bit
Version: 4.3.3.2
Build ID: 430m0(Build:2)

and

Version: 4.4.0.0.alpha2+
Build ID: 5bff4b016c4b44f4123e0e6a4fd4c0c4dc0cfa2d
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-11-13_00:14:29
Comment 5 Robinson Tryon (qubit) 2014-12-23 19:58:06 UTC
(In reply to nick.dyer from comment #2)
> Look at the image I attached, it might not be reproducible on your platform.

Yeah, looks bad

(In reply to nick.dyer from comment #0)
> Steps to reproduce:
> 1. Undock sidebar
> 2. Resize sidebar window
> 3. Change sidebar type

TESTING with LO 4.4.0.1 + Ubuntu 14.04

> Current behavior: Sidebar buttons appear in middle of window on top of other
> UI elements

NOREPRO from my end.

Nick: Can you still reproduce the problem with the 4.4.0.1 RC?
Anything special about the Ubuntu install you're using?
Comment 6 Nick Dyer 2014-12-24 10:29:11 UTC
It's a clean install of ubuntu trusty 14.04.

I can confirm, the problem doesn't seem to be there in 4.4.0.1 as downloaded directly from libreoffice.org - everything resizes properly.
Comment 7 Robinson Tryon (qubit) 2014-12-24 16:43:22 UTC
(In reply to Nick Dyer from comment #6)
> It's a clean install of ubuntu trusty 14.04.
> 
> I can confirm, the problem doesn't seem to be there in 4.4.0.1 as downloaded
> directly from libreoffice.org - everything resizes properly.

Sounds like two possibilities here:
1) The bug is fixed in 4.4
2) The bug is Ubuntu-release-specific

Either way, this appears to be fixed for TDF builds, so Status -> RESOLVED WORKSFORME.

If the problem isn't fixed when Ubuntu releases 4.4, I'd suggest that you file a new bug against Ubuntu (on Launchpad).