Download it now!
Bug 83559 - CJK: Entering Chinese in Writer
Summary: CJK: Entering Chinese in Writer
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2014-09-06 13:09 UTC by sivin
Modified: 2014-10-03 18:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sivin 2014-09-06 13:09:16 UTC
Problem description: When I install the “Chinese, China” facility in order to type Chinese, for a few days I can switch into Chinese using the default ctrl-space hotkey, but then it stops working, and the only way I can switch languages is to click on the icon in the status bar. Removing and reinstalling Chinese does not fix this bug.

Steps to reproduce:
1. Install Chinese, China, with default ctrl-space to activate Chinese
2. Do ctrl-space

Current behavior: nothhing hhappens

Expected behavior: entry of Chinese characters toggles on

              
Operating System: Linux (Other)
Version: 4.2.4.2 release
Comment 1 Matthew Francis 2014-09-25 00:51:44 UTC
Could not reproduce on Ubuntu 14.04

You don't mention which exact Linux distribution you're using, but this sounds more like a distribution level issue than something specific to LibreOffice.

I have previously seen a similar issue where Chinese input has become confused when first installed - removing and reinstalling is not enough to cure this, you have to actually log out of the user session before it comes back.
Comment 2 sivin 2014-10-03 18:05:19 UTC
I am using Linux Mint v. 17 Mate. 

I have discovered that this is probably related to my use of a portrait-mode monitor (see below). When I set the screen to landscape mode and got rid of Chinese, rebooted, and reinstalled Chinese, I could use the default ctrl-space to toggle between Chinese and English (except that I have to do ctrl-space twice). When I reset the screen to portrait mode the toggle  (ctrl-space twice) still works.