Download it now!
Bug 83607 - segfault when moving with Shift down in specific document
Summary: segfault when moving with Shift down in specific document
Status: RESOLVED DUPLICATE of bug 82777
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2014-09-08 11:37 UTC by Cor Nouws
Modified: 2014-09-08 15:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test document for crash (29.03 KB, text/odt)
2014-09-08 11:38 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2014-09-08 11:37:02 UTC
I'll attach a Writer document

– place cursor in front of placeholder field START (5th line)
– press Shift+Down twice (crossing page break)
  > Crash


My version
Version: 4.4.0.0.alpha0+
Build ID: 1298c1d13572c6fbfbabb813b2d6843368c6df1f
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-08-29_00:42:19

Ubuntu 32 bits
Comment 1 Cor Nouws 2014-09-08 11:38:21 UTC
Created attachment 105889 [details]
test document for crash
Comment 2 Cor Nouws 2014-09-08 11:39:12 UTC
doesn't crash in 4.3.1.2 > regression
Comment 3 Cor Nouws 2014-09-08 11:43:12 UTC
easier to reproduce:
any selection with Shift+Arrow on page 2 makes the thing crash
Comment 4 Jacques Guilleron 2014-09-08 14:19:09 UTC
Hi Cor,

I reproduce the crash with LO 4.4.0.0.alpha0+
Build ID: 37b9ea92ba81d74764a2345a9c75c65bfd272d2b
TinderBox: Win-x86@42, Branch:master, Time: 2014-08-26_09:37:01
& Windows 7 Home Premium.

This doesn't happen with LO 4.3.1.2
Build ID: 958349dc3b25111dbca392fbc281a05559ef6848

With LO 4.4, on the second page, if you change frame anchorage from Page to Paragraph, there's also no longer crash, but the selection by Shift arrow is not the same and include now the frame.

I set status to NEW.

Regards,

Jacques
Comment 5 Terrence Enger 2014-09-08 15:57:21 UTC
Based on the facts that
(*) Ctrl-A in the attached .odt also crashes with a segfault.
(*) The crash with the STR from the bug description and the crash from
    Ctrl-A came into LibreOffice in the same day, as determinde from the
    daily dbgutil bibisect repository.
(*) The crashes on this document and the backtrace attached to bug
    82777 both show a constructor of SwNodeIndex--albeit not the
    constructor--in frame #0 of the call stack.
I guess that this is a dup of bug 82777, and I am resolving the bug
accordingly.


Meanwhile, from `git bisect good`:

    ba5b58a62db37685dbd283123bd62fbd2458f4c7 is the first bad commit
    commit ba5b58a62db37685dbd283123bd62fbd2458f4c7
    Author: Miklos Vajna <vmiklos@collabora.co.uk>
    Date:   Wed Aug 13 08:48:59 2014 +0200

        2014-08-13

    :100644 100644 f4798ad03594b7db8a08f376fed5ff5369de2224 dd7293520470d3934353227414231a1bc2afc81d M	build-info.txt
    :040000 040000 8fa6ace9bb0cdd432e72fecee3ce43ff806948f9 1e2fc1aec541730d5ba0af50b233df1304047b21 M	opt

and from `git bisect log`:

    # bad: [8fa53af1a54e2ad70800e5fd034968c80b589db7] 2014-09-08
    # good: [b3130c846de5cf1b4be48b48dfc780bb369549fa] 2014-05-21
    git bisect start 'origin/master' 'oldest'
    # good: [cbed87a20815ddd7af3afb31aa2fc7a29383ce89] 2014-07-14
    git bisect good cbed87a20815ddd7af3afb31aa2fc7a29383ce89
    # good: [6b0c7213477d9c4ebf74bdf74871a684f1a9b6dd] 2014-08-11
    git bisect good 6b0c7213477d9c4ebf74bdf74871a684f1a9b6dd
    # bad: [f5043baf54256feb23ca38332261eaad621d0c21] 2014-08-25
    git bisect bad f5043baf54256feb23ca38332261eaad621d0c21
    # bad: [01a231ecccc1ea6df8c0232a2671315260c0155f] 2014-08-18
    git bisect bad 01a231ecccc1ea6df8c0232a2671315260c0155f
    # bad: [281bb640c24ce71fd3bf40bf1cba2d7c72566456] 2014-08-14
    git bisect bad 281bb640c24ce71fd3bf40bf1cba2d7c72566456
    # bad: [ba5b58a62db37685dbd283123bd62fbd2458f4c7] 2014-08-13
    git bisect bad ba5b58a62db37685dbd283123bd62fbd2458f4c7
    # good: [59a8d89d4255a1cbcab4fcfeff9270dd56c62aed] 2014-08-12
    git bisect good 59a8d89d4255a1cbcab4fcfeff9270dd56c62aed
    # first bad commit: [ba5b58a62db37685dbd283123bd62fbd2458f4c7] 2014-08-13

The source hashes, taken from the title bar of the Writer window are:
    no crash  : 886e4ed
    yes crash : 0da2a54

*** This bug has been marked as a duplicate of bug 82777 ***